1

Good morning,
I'm working on a Windows 10 virtual machine, where some scheduled tasks are defined. Yesterday I've been working with those, by doing the following (the action is the launching of a batch-file): Copy the mentioned batchfile to a second one (modifying the "action" part of the scheduled task) and launch that second one. Put the original batchfile back (by modifying the "action" part again to its original setting).

Now I've seen that nothing has been done: the second batchfile has not been run, and now even the original batchfile is not run anymore (although it should, following the schedule).

In the history, I've found back following warning (in fact, it's an error message):

Task Scheduler did not launch task "\<taskname>"  because user "<computer_name>\<username>" was not logged on when the launching conditions were met.
User Action: Ensure user is logged on or change the task definition to allow launching when user is logged off.

As I have no clue what this means, I have compared the settings of the corresponding task with the ones of a task which is still working. Both are equal on only one difference, more exactly in the "general" tab of the task definition: for the tasks which are still working, the mentioned username "When running the task, use the following user account:" is written in capital letters, while for the task which is failing this entry is written in small letters.

As Windows is supposed to be case insensitive, this should not impact the behaviour, but as it's the only difference between a working and a failing task, I'm tempted to think that this might be an issue indeed. In top of that, the user account which is mentioned is just written as "<username>" (without mentioning the computer name). Is this correct? Meanwhile I've investigated the scheduled tasks as they are stored in registry, they seem to be stored as subkeys of:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks

There I've seen that my two tasks are both referring to the same user account, so this is not the reason of this problem.

It seems like two different tasks, configured in exactly the same way, give different results.

Does anybody know how to help me out of this?
Thanks in advance

bumped to the homepage by Community 15 hours ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

0

Meanwhile the problem has been solved, by modifying the user of the scheduled task, but there is a catch: there was mentioned: <username> while for other tasks there was mentioned <USERNAME> (mind the capitals).
It now seems that <USERNAME> is the display name for <domain>\<username>, so by replacing <username> by <domain>\<username> the problem has been solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.