0

I have a Windows 7 Professional machine that I'm using as a RDP server. I've used RemoteAppTool to generate a .RDP file to connect to a RemoteApp application.

Below is the .RDP file:

allow desktop composition:i:1
allow font smoothing:i:1
alternate full address:s:Foobar
alternate shell:s:rdpinit.exe
devicestoredirect:s:*
disableremoteappcapscheck:i:1
drivestoredirect:s:*
full address:s:Foobar
prompt for credentials on client:i:1
promptcredentialonce:i:0
redirectcomports:i:1
redirectdrives:i:1
remoteapplicationmode:i:1
remoteapplicationname:s:PeachRA
remoteapplicationprogram:s:||PeachRA
span monitors:i:1
use multimon:i:1

This RDP file works fine from a Windows 10 client machine. However, it does not work from either a Macbook Pro (using the Microsoft Remote Desktop client) or a Chromebook (using the Xtralogic RDP client) - it cannot find the server on these machines.

The .rdp file has full address set to Foobar.

However, I cannot ping Foobar from the Macbook Pro. I tried pinging this from the Windows client machine, and it seems to resolve to a IPv6 address:

C:\Users\AVS Office>ping Foobar

Pinging Foobar [fe80::d8f8:80f1:1492:9ee3%9] with 32 bytes of data:
Reply from fe80::d8f8:80f1:1492:9ee3%9: time<1ms
Reply from fe80::d8f8:80f1:1492:9ee3%9: time<1ms
Reply from fe80::d8f8:80f1:1492:9ee3%9: time<1ms

This is the ipconfig from the Windows 10 client machine:

C:\Users\AVS Office>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Office-XXX-2
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : D8-50-E6-BA-XX-XX
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::197f:d1f5:8fd2:3418%9(Preferred)
   IPv4 Address. . . . . . . . . . . : 10.1.1.11(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.0.0.0
   Default Gateway . . . . . . . . . : 10.1.1.1
   DHCPv6 IAID . . . . . . . . . . . : 249057510
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-D0-4B-B5-D8-50-E6-BA-89-51
   DNS Servers . . . . . . . . . . . : 10.1.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet1
   Physical Address. . . . . . . . . : 00-50-56-C0-00-01
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::4850:26e2:aa65:f8fb%5(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.48.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Wednesday, 16 November, 2016 4:24:29 PM
   Lease Expires . . . . . . . . . . : Tuesday, 22 November, 2016 11:24:37 PM
   Default Gateway . . . . . . . . . :
   DHCP Server . . . . . . . . . . . : 192.168.48.254
   DHCPv6 IAID . . . . . . . . . . . : 67129430
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-D0-4B-B5-D8-50-E6-BA-89-51
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{F2493FFC-B6B8-4BE4-BF58-E26DC84389CB}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{8464D47A-BE0F-46F8-BDE2-3055AF381849}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

I believe the Foobar server also has an IPv4 address (10.1.1.2) - I've tried setting the .RDP file to point to this. It does connect, but the RemoteApp feature doesn't work - it seems to open a full-screen RDP connection.

Firstly, why is the Windows client able to connect via IPv6, but the MBP and Chromebook are not?

Secondly, why would connecting via the IPv6 address make a difference, versus using a IPv4 address, specifically for the RDP RemoteApp feature?

  • Firewall rules? – Lenniey Nov 22 '16 at 13:49
  • @Lenniey - I don't believe so - the MBP doesn't have a firewall enabled. For Chromebooks, I'm pretty sure these don't either. – victorhooi Nov 22 '16 at 13:53
  • No I meant the firewall rules could block the IPv4 RDP connection but allow IPv6. Also: if your Win7 machine registers its IPv6 address in DNS, you obviously connect via IPv6. Do your other clients (MBP / Chromebook) have IPv6 enabled at all? – Lenniey Nov 22 '16 at 14:00
  • Interesting - so you're saying check the firewall on the Windows 7 Professional RDP server? Sure. However, the thing is - I can do a normal full-screen RDP session to that machine via the IPv4 address (10.1.1.2) - but it's the RemoteApp connection that doesn't seem to work correctly. MBP and Chromebook do support IPv6 in theory - not sure why they're not picking up a IPv6 address here in this case though. – victorhooi Nov 23 '16 at 13:27
  • I'm a bit confused...did you find the error? Does it work at all, even if not like you wanted it to? – Lenniey Nov 23 '16 at 15:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.