My root partition was filling up, with only 500 mbs left, I wanted to resize my root partition from 20 Gb to 40Gb

So I resized my partition by using these steps:

  1. Using Gparted to resize another partition to give space for the EXT4
  2. Using fdisk, deleting the root partition (on /dev/sda2), and creating it again using the new size
  3. resize2fs /dev/sda2
  4. Updating grub2

But now the problem is that although I can boot in my new partition and the new partition shows it is 40Gb, but the free size was still 500mb. So I booted from a LiveCD and checked with e2fsck -p /dev/sda2, it reported clean. So I added the -f flag (force check), still, the drive is full.

  • sudo fdisk -l please. – Bobby Mar 1 '10 at 13:11
  • and add the filesystem size info from sudo tune2fs -l /dev/sda2 – quack quixote Mar 1 '10 at 14:37
  • thanks, but I used gparted to check partition and it just fixed it for me – TiansHUo Mar 3 '10 at 6:37

I used gparted under livecd to check partition and it just fixed it for me.

| improve this answer | |
  • 3
    Consider accepting your own answer by marking it as such, if this fixed your problem. – Gnoupi Apr 8 '10 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.