1

SEE UPDATES

So, got this Innostor-based 1f75@0611 SATA/PATA to USB 3.0 adapter with external power supply. (System: Windows 7 x64, laptop HP Envy dv7)

  1. Connected to USB 3.0 port - no matter which one, the result is same: after copying some files (10-20 or 100-200 mb) to PATA disk, it hangs.
  2. Hanging means: the copying application (and its process) does not close/pause/terminate/anything. Any other application which works with HDDs (e.g. DISKPART or HDDScan or Victoria) do not start (process appears, but that's it - stuck), explorer also refuses to terminate, windows does not restart etc. etc. etc. The ONLY way I found to fix this was manually disconnecting that adapter. Actually the problem is hearable: drive spins up, then writing starts (silent crackle) - then crackle stops at the moment when hanging occurs - after some minutes drive spins down because of being idle.
  3. Tried HDDScan - hangs on 1% of test.
  4. Tried HDDLLFT - hangs on ~20% of test.
  5. Reading works perfectly.
  6. Checked SMART for disk - ~ 1.5 mil of CRC errors, 2 Reallocated Events, 13 Reallocated Sectors.
  7. Connected that PATA to USB 2.0 port (luckily had that one) - everything works almost as expected. Copied 500 mb of files just for testing - all good. Executed Victoria test - hanged on ~27% of surface. Restarted it from a moment before - it passed till the end.
  8. Decided that this one is now working. Started a copying process of 100Gb from SATA (via that adapter) to this PATA (via same adapter - adapter allows up to 3 device at same time). Hanged at ~35% (copied via Total Commander, which also refused to cancel/gotobackground/close/terminate etc).
  9. Went to cmd (system being hanged at the moment) and cd-ed into SATA disk - fail, cmd hanged.
  10. CD-ed into that PATA disk - success. I can see the root dir and even go into first dir in that root dir. However when tried to go into dir at 2nd level (root-mydir1-mytargetdir) cmd hanged.

Questions to you, guys: this is not SATA or PATA connection - why does system hang? Any other way to reconnect except hard reconnection of adapter? Any ideas on the source of this problem? Any ideas on how to fix this?

P.S. Adapter bought from abroad, I need to know whether it is fully broken, partly broken or not adapter's problem - to decide which refund to ask for from seller.

UPDATE 1: Updated all drivers. Was copying files in USB 2.0 mode from SATA to PATA. One file got constantly stuck on. I decided to first copy to PC and then copy from PC. But it appeared that this stuck (again, hanging!) problem was in SATA device! I couldn't copy file to PC. But as soon as I connected adapter to USB 3.0 port, I could copy that file. Of course it's not 100%, but here is what I think of now: the adapter has problems with reading SATA on USB 2.0 and has problems with writing PATA on USB 3.0. In all other situations all seems fine. But that's not 100%!

  • 1
    I am not aware of any reputable bridge of USB 3.0 to Parallel ATA interface. This does not make any business sense: there is no PATA drives on the market anymore. I know only USB 2.0 to PATA bridges. The device 1f75@0611 has appeared in the market in 2013. I am afraid this is some crappy bootleg design that can't pass any functional certifiction. Throw it away. If you need to get access to old PATA drives, get a basic USB2 to PATA enclosure, and save your data into some modern storage. – Ale..chenski Nov 23 '16 at 0:28
  • Can you post an image of what the USBview.exe utility shows when you connect all three drives to the adapter? – Ale..chenski Nov 23 '16 at 2:50
  • Sure, here it is. [s12.postimg.org/gviarel0d/xxx.png] – Matilda Bentefor Nov 23 '16 at 12:54
  • The USBView output looks strange. The external device appears as internal "root hub", which seems impossible. If you disconnect your cable, what the USBview will show? Also, could you enable descriptor view? Maybe the entire export of USBview data is possible to attach? – Ale..chenski Nov 23 '16 at 16:53
  • Actually the "Config Descriptors" is enabled. When I disconnect cable, that field shows "NoDeviceConnected" – Matilda Bentefor Nov 24 '16 at 1:28
0

A drive (any, not only a hard disk drive connected by PATA/SATA) can hang the application. The system is still trying to communicate and is waiting for a proper response. If the application doesn't have any time out protection then it hangs...

If the hard disk drive has an interface problem, then it is possible to hang often on faster communication.

Did you scan & repair using some hard disk drive repair tools (for example mhdd)? It probably only marks bad sectors, but after that it is possible that you can use it without hangs.

  • Drive can hang application - but not entire system! Also: I highly doubt TC, diskpart, copy tool, teracopy etc etc all don't have timeout. Regarding scanning and repairing on low level - I will do that. But maybe anything can be done with my current laptop? – Matilda Bentefor Nov 22 '16 at 20:34
  • system use fifo or other queue system, if one task stop other also waiting... – Adam Silenko Nov 22 '16 at 20:38
  • Really? In multicore PC? Or you mean that entire USB 3.0 host that I have is single-threaded? – Matilda Bentefor Nov 23 '16 at 12:56
  • not task like service or process, I/O task can cause long waiting, for user it looks like system hang, but if you disconnect drive this task will be terminated – Adam Silenko Nov 23 '16 at 22:29
  • It's 2016 and still one bad cable/disk over USB can hang entire system. Damn. – Matilda Bentefor Nov 24 '16 at 1:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.