3

What I'm trying to achieve:

I'm trying to use my Raspberry Pi 3 as a wifi hotspot.

I'd like to use only wifi to achieve this (I could need it in places where I wouldn't have internet access with ethernet).

So I was following these steps from the archlinux wiki to have both wifi client and wifi access point with a single wifi device.

My current situation :

I checked with iw list :

Wiphy phy0
...
     Supported interface modes:
         * IBSS
         * managed
         * AP
         * P2P-client
         * P2P-GO
         * P2P-device
...
     valid interface combinations:
         * #{ managed } <= 1, #{ P2P-device } <= 1, #{ P2P-client, P2P-GO } <= 1,
           total <= 3, #channels <= 2
         * #{ managed } <= 1, #{ AP } <= 1, #{ P2P-client } <= 1, #{ P2P-device } <= 1,
           total <= 4, #channels <=
...

My wifi device (the Rpi3 wifi chipset) seems able to handle the Wifi as access point (I managed to make it behave as one and opened a ssh session with it using hostapd and dhcpd).

If I understand this output well, it also supports both AP and client mode.

My Rpi state when the problem occures :

I disabled the hostapd and dhcpd4.service with systemctl, and I shut wlan0 down using ip link set dev wlan0 down.

The actual problem :

Then I tried to add the two virtual interfaces (as root) I got this :

# iw dev wlan0 interface add wlan0_sta type managed addr 12:34:56:78:ab:cd 
command failed: Device or resource busy (-16)     
# iw dev wlan0 interface add wlan0_ap  type managed addr 12:34:56:78:ab:ce
command failed: Device or resource busy (-16)

Same result when trying with phy names or with wlan0 up.

What could I try to solve this?

2

Actually, it looks like I misunderstood the iw list output.

If the RPI3 chipset was able to behave like this, the two mode it could use simultaneously would be between the same #{...} in the iw list output.

The person helping me on IRC with this also suggested me to use a Wifi dongle to solve this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.