I'm trying to put an unused 2007 HP Proliant ML150 G3 server to use at the office. I was told it just needed a new PSU which i've installed but the thing won't boot up. After powering it up, the fans come on, it seems to run the BIOS fine, but after the summary i just get a black screen with a flashing cursor in the top-left corner.

There are no error messages, no beeps - nothing. I can't input on the keyboard, i can just ctrl-alt-del to restart it. I can enter the setup though and I've changed the boot sequence and tried booting from a Windows Server OS DVD but i get the same sequence everytime.

Has anyone got any theories please???



If possible, reset the CMOS, by either using the jumper that should be on the mobo, or taking out the watch battery. It's possible something is misconfigured and this will bring it back to factory state. Something is def. 'breaking' before even boot up can start, since it won't even boot from a windows os dvd.

make sure the server has a dvd drive and not a cd drive

take out all the hard drives, and try booting from a linux live cd, then the windows setup dvd

  • Jeez! You wouldn't think HP would fit a 2007 server with a CD-ROM drive, but they did! Swapped it out for a DVD drive from another machine, had to reset CMOS and disconnect the hard drives initially but it works now. Many thanks. – Ho Li Cow Mar 3 '10 at 14:16

Are there any expansion cards that are non-HP? I have seen this with eSATA adapter in a couple of our servers. Remove and try again. You could also just remove ANY expansion cards if possible and see what happens.

  • Thanks for replying. No, it's not got any expansion cards in at all. – Ho Li Cow Mar 3 '10 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.