I am using a number of different keyboard layouts, depending on which language/keyboard I am woring with. Some of these rely on the AltGr key for producing certain symbols like @ (e.g. the Swedish layout).

Since I updated to Windows 10, the AltGr key intermittently ceases to work (while Ctrl + Alt + still works). Similar issues have been reported with Win 8 and Win 8.1, but the solutions to these do not apply to my case (and perhaps not to other Win 10 cases. So I will try to be very precise in describing the issue here.

To start with, when I say "the AltGr key stops working", what I mean is that it fails to act as Ctrl + Alt (which is what it is supposed to do). However, it does do something: for example, when I press AltGr + 2 and then another ordinary key, say "A" what I get is "2a". Note that the 2 does not appear until I press the "A". In other words, when pressed with AltGr, the "2"-key is somehow treated like a dead key.

Changing between different keyboard layouts does not help. AltGr will not work neither in those other keyboard layouts nor in the original one when I switch back to it. The only way to get AltGr working again seems to be to reboot the system (though I have also seen instances where a reboot from a system with a working AltGr key led to a system with a non-working AltGr key).

It also does not make a difference whether I use the Windows 10 screen keyboard or the hardware keyboard. In the case of the On-screen keyboard, pressing the AltGr key correctly displays the characters on those keys that have one assigned to them (in combination with AltGr), but despite this, tapping one of those keys does not produce the displayed character.

  • Does it help pressing one of the following key combinations: left alt+space, alt+shift or ctrl+shift? These are keyboard shortcuts for changing between langage and/or layout and may be the cause of your problem. Yes, I read that changing keyboard layout doesn't fix it, still please test this. – LPChip Nov 23 '16 at 22:00
  • 1
    I have long turned off those language changing shortcuts (they were driving me nuts). So: no, pressing these key combination does not help. – Christoph Nov 24 '16 at 1:50

The issue happens when you open a RDP connection. Just bring the RDP window in foreground and press Alt+Enter.

The issue will disappear on all other windows too

Source: How to Fix Alt Gr Key Not Working.

  • 2
    This should be the accepted answer! Been looking for a solution for this weird problem for ages. Until now I had to close an reopen my RDP sessions. Thanks for this Alt+Enter finding! – MemphiZ Jan 19 at 10:49
  • You saved my day – tanathos Feb 7 at 11:13
  • My AltGr-key is gone after sleep if I had a RDP-session on when I closed the lid. To get the AltGr back, all I had to do is open the RDP-session and tap AltGr there. Then it stats working on my Windows-side too. Really weird bug. – Jari Turkia May 22 at 8:01
  • Great stuff! Solved the problem. Thanks. – Resource Sep 17 at 9:59
  • Works perfectly. In my case, it was one of many RDP Windows, trying them one at a time worked in the end :) – Calciol Oct 10 at 7:13

In my case left Shift+Caps Lock+AltGr helped. I have no idea what it does, but it works.

  • 1
    This is the only solution that worked for me, thanks! I can't find any info as to why this shortcut exists either, sadly. – Flater May 16 '17 at 11:49
up vote 0 down vote accepted

It turns out that, in my case, the reason for this was wincompose, a program that I had uninstalled but for unknown reasons that uninstall partially failed so that the core of the program was still running in the background and interpreting some of my AltGr keyboard inputs as shortcuts (without any function).

This question has been extremely popular over the past few months, which means that many people are facing similar issues. Most likely, this will not be the solution for them, but I hope that more answers will eventually come up so that everyone finds a solution.

Some utility programs can also "steal" the keyboard stroks.

In my case it appeared that the VirtualDesktopManager resulted in non-functional AltGr, so I could not write [ and ].

On my black widow keyboard I solved this by turning off the macro button for AltGr+Fn.

In my case i solved it by noticing the problem fast after the problem was installed wich in this case was fortnite stealing the keybind for ALT (left&right)

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.