3

I'm running a couple of Windows 10 guests on Workstation 11, which is running on Windows Server 2012 R2 Essentials (the host). The VM's have bridged network connections. I do not have "Replicate physical network connection state" checked.

The guests work fine until suddenly, they report "no Internet connection." When this happens, the host's network connection is fine (from the host I can open a browser and get to any site, no problem). A short term fix (until it happens again, which can be anywhere from 3 to 20 minutes), is to VM > Removable Devices > Network Adapter > Disconnect and then VM > Removable Devices > Network Adapter > Connect. After doing this, everything is fine for a short while, then the connection is dropped again.

I shut down the VMs, and restored the Network Settings to their default values (I never changed them after installing Workstation) hoping that would resolve the problem, but it hasn't made any difference at all.

The problem occurs in both VMs, but not necessarily at the same time. One VM can have a working bridged connection and the other reports no connection, or both have no connection.

Any ideas what is causing this problem?

1

I believe I found the source of this problem. I am running VMWare Workstation on a physical machine with two NICs. This machine is connected to my router via a single cable to one of the two NICs. There is no connection on the other NIC.

All of my VMs use a bridged network connection. From Workstation's Virtual Network Editor click on VMnet0. On my system the type for this VMnet is Bridged and the External Connection is Auto-bridging. Then in the VMnet Information section the selected connection type will be Bridged and Bridged to: will be set to Automatic. Click on Automatic Settings... This brings up the Automatic Bridging Settings dialog box (see image). Make sure only the active NIC is checked. On my system, both were checked and it wasn't until I unchecked the inactive NIC that my VM connection problem went away.

I consider this a bug in VMWare Workstation. There is no IP address associated with the inactive NIC. So why would leaving that box checked cause Workstation to attempt to use it (perhaps, thinking it was load balancing)?

enter image description here

0

when your configuring LAN adapter with static IP in VM there will be an option like save the network settings when the LAN adapter is removed you can use that

and make sure that your LAN adapter is configured with static IP and static MAC ID

I hope you will find the solution

  • The VMs are configured with DHCP. The host is configured with static IP. Why should the VMs be configured with static IPs? – mbmast Nov 24 '16 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.