1

I'm creating a website and uploading files onto that website with FireFtp. When I don't do anything on FireFtp for 120 seconds and then try to do something, I get the following error message:

421 Timeout (no operation for 120 seconds)

FireFtp disconnects from my account automatically after 120 seconds and I have to log in again. After a while, this gets quite annoying.

Why is this? Is there a way to keep it from happening?

0
  1. Open FireFTP URL and press Shift+Alt+T (Alternatively click on Tools in its menu bar).
  2. Go to Options.
  3. Then to Connections.
  4. Below Connection Recovery you can set Network Timeout option to a value between 1 and 600. Your current value must be 120.

Also check if your Keep alive connection while idle option is checked.

| improve this answer | |
  • 1
    My current value of Network timeout is 30 and the Keep alive connection while idle is checked. I tried to change the value of Network timeout from 30 to 600, but after 120 seconds, it still gives the error message "421 Timeout (no operation for 120 seconds)". – Donald Duck Nov 22 '16 at 19:46
  • 1
    Then I guess it is a limitation imposed by the server. Do you have access to the FTP server configuration files? – another Nov 22 '16 at 20:06
  • Tecnically with these changes your configuration is correct. I am afraid that the limitation depends upon the FTP server. – another Nov 22 '16 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.