6

Trying to start up Hello World application in Docker Toolbox.

OS: Windows 7 Professional SP1

Installed from here, no errors during install.

Ran 'Docker Quickstart Terminal', and typed

$ docker run hello-world

and I get

Unable to find image 'hello-world:latest' locally
latest: Pulling from library/hello-world
c04b14da8d14: Pulling fs layer
E:\Sanjay\Tensor\Docker Toolbox\docker.exe: open /mnt/sda1/var/lib/docker/tmp/Ge
tImageBlob474134307: read-only file system.
See 'E:\Sanjay\Tensor\Docker Toolbox\docker.exe run --help'.

any ideas how to proceed?


Not sure if this helps:

$ docker info
Containers: 0
 Running: 0
 Paused: 0
 Stopped: 0
Images: 0
Server Version: 1.12.3
Storage Driver: aufs
 Root Dir: /mnt/sda1/var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 0
 Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
 Volume: local
 Network: null host bridge overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Security Options: seccomp
Kernel Version: 4.4.27-boot2docker
Operating System: Boot2Docker 1.12.3 (TCL 7.2); HEAD : 7fc7575 - Thu Oct 27 17:2
3:17 UTC 2016
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 995.8 MiB
Name: default
ID: O5YY:NXSQ:PYYI:HHGU:6ZN3:3U7H:DICU:3QWV:ABUJ:EUFR:MAEU:MMNN
Docker Root Dir: /mnt/sda1/var/lib/docker
Debug Mode (client): false
Debug Mode (server): true
 File Descriptors: 15
 Goroutines: 27
 System Time: 2016-11-24T18:11:38.478659087Z
 EventsListeners: 0
Registry: https://index.docker.io/v1/
Labels:
 provider=virtualbox
Insecure Registries:
 127.0.0.0/8

2 Answers 2

3

I loaded Docker on an old win8 machine, and things ran fine. I came back later and got the same problem as you. Here is what I did. First you need to find the name of your docker machine:

$ docker-machine ls

Then with your machine name, run the command

$ docker-machine restart <name>

and that did the trick for me. I don't know why it worked.

1

I have had problems with some folders, and it turned out to be Windows permissions problems. I could not fix these through Windows itself, but had to use CygWin terminal to run the good old chmod command.

DISCLAIMER: I'm not a windows security guru, and can't speak to the overall security ramifications of the following actions! Use at your own risk! Also, there is no 'clean' way to undo these actions.

Opening a CygWin terminal and running ls -l in my c:\Users\<user> directory, I saw the following;

$ ls -l 
total 1417
drwxr-x---+ 1 SYSTEM         SYSTEM      0 Dec 11 06:23 Desktop
-rwxrwx---+ 1 Administrators SYSTEM    174 Mar 18  2017 desktop.ini
drwx------+ 1 SYSTEM         SYSTEM      0 May 15  2017 Documents
drwx------+ 1 SYSTEM         SYSTEM      0 Aug 22  2013 Downloads
drwx------+ 1 SYSTEM         SYSTEM      0 May 15  2017 Libraries

Note the files aren't owned by the user, and the access privileges are set only to the owner. I first tried changing the owner to my username, using chown and that didn't seem to work. So next I tried this command to open up permissions on directories;

$ find . -type d -exec chmod 0770 {} \;

This resulted in these permissions on all of my directories;

$ ls -l
total 14059
drwxrwx---+ 1 rooster SYSTEM       0 Nov 18 16:36  Desktop
drwxrwx---+ 1 rooster SYSTEM       0 Dec 11 16:58  Documents
drwxrwx---+ 1 rooster None         0 Dec 12 11:05  Downloads

After this, I had no problems.

Given the chown alone seemed to have no effect, I recommend trying the chmod first, and then maybe chown if the chmod alone doesn't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.