My HP LaserJet P1102w printer is set up to be operated wirelessly. It works just fine from my PC. However, that is not universal.

For example, my Android phone is connected to the same Wi-Fi network, so it should be able to see the printer. However, the printer just doesn't show up in the list, even though I successfully installed the HP Print Service and turned it on.

I tried updating the firmware for the printer and tried to manually add the printer to the list by typing in its IP address - nothing helps.

How do I make the printer show up on the network for all computing devices?

  • @DavidPostill The question is not about setting up a smartphone, it asks how a printer should be set up so that it can interface with Android smartphones. To me that's clearly on-topic. I've created a Meta question to discuss this. – Malcolm Nov 26 '16 at 0:12
  • 2
    Close voters: see the discussion on the Meta site. The problem was discovered trying to connect an Android phone, but it isn't a phone-related problem, it's a networking issue (see the self-answer). The problem could also occur with PCs. – fixer1234 Nov 26 '16 at 3:44

It turns out that the vital setting is the Bonjour service on the printer, which helps with the network discovery. It can be turned on by going to the Web interface of the router - just need to type the IP address of the router.

There is a networking tab, and it has the item "Bonjour" on the left. When you click it, the pane on the right will have a setting to turn Bonjour on which you need to click, and also you can set the printer's name there. It will show up in your phone under this name. After you apply the changes in settings, you need to try scanning for the printers again, and it will show up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.