With Hyper-V, I created a expandable VHDX file with Windows 10 installed inside, whose max-size just equals the size of the partition it stores. Blue screen came out saying "VHD_BOOT_HOST_VOLUME_NOT_ENOUGH_SPACE" when native-booting.

I know M$ requires that there must be free space on the partition in case VHDX expands to maximum. (Plus the space of the page-file, as is said in MSDN .)

It means if you claim that much space, it must be reserved, no matter allocated to a traditional partition, occupied by a fixed-sized VHDX, or just left on the disk for an expandable VHDX (though may shared by multiple ones).

However, I would like to take care of it myself to utilize the free space not yet used. Since the VHDX will be my system drive, it is hardly possible that I wouldn't notice it before it grows too large.

I wonder if there are any tricks to by-pass this error?

1 Answer 1


There is an entry VirtualDiskExpandOnMount under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\FsDepends\Parameters in the registry that can be set to the value 4, to disable the expending of the VHDs.

  • Sorry for my late response. Should I edit it inside the VHDX? Outside the VHDX there is no Windows installed on the physical drive, but a Windows boot-loader contained in folder \Boot and folder \EFI, which will load the VHDX while native-booting.
    – Schezuk
    Nov 28, 2016 at 2:43
  • configure this inside the registry of the Windows that is inside the VHD. Nov 28, 2016 at 5:12
  • @magicandre1981 how can you configure the registry inside the VHD windows if you can't even boot it. Feb 4, 2020 at 10:03
  • 1
    @RedaDrissi mount the VHD, run regedit, load hive and edit the value Feb 4, 2020 at 15:39
  • @RedaDrissi does it work? Feb 19, 2020 at 15:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .