0

I know my questions looks similar to others, but they have not been answered as to solve my problem. I'm from Mexico. I got an ASUS S451L. I got the computer with windows 8 then I upgraded it with windows 10. A week ago I got a virus and lost all my data, so I decided to install Ubuntu 16.04, because I read good reviews about it. I was very excited, but after I installed. I tried to get my favorites videogames (LoL;GuildofWars2) running but they wouldn't work on Linux. Yes, I installed Wine and play on Linux. I had to installed Ubuntu again because after trying to install GW2, it crashed.

I got tired and decided to go back to windows. Unfortunately, I never backed up windows; I was afraid I deleted forever, so people told me to buy a new license or get it pirate. But somehow , reading forum, I got to know if I still had the ISO. the only problem was that I couldn't boot it. GRUB would get on the way. Anyways, I repaired the boot loader using that Ubuntu application Boot-repair. I got to the command thing where I can type bootrec /Fixboot or /Fixmbr. It told me that the processes were succesful. But it was still booting GRUB. I prioritize Windows Boot manager (yes , it gave me theoption) but it wouldn't boot it. I uninstalled UBUNTU hoping it would stop booting GRUB, but it was still booting (in a blackscreen with inframes thing). In conclusion, it is not booting windows and evennthough I got a Windows 8.1 PRO iso, it sends me an error of compatibility:

"The computer started using Windows Installation media. Remove the installation media and restart your computer so that Windows starts normally. Then, insert the installation media and restart the upgrade. [DO not select !custom [advanced] to perform an upgrade. !custom advance installs a new copy of Windows and deletes your programs and settings/" I read something that said this happened because it read the booter my computer has as default. I have my key license. I just need to boot Windows 8 so I can install it. Is it possible? What could I do? Am I doomed? Will Yuri ever marry Victor? HELP ME !!

Greetings !

P.S. sorry for the long post. P.S.2 I don't know anything about programming or those things in case you didn't notice. P.S.3 I tried the DISKPART thing but it didn't do anything when I typed the coomand "ren bcd bcd.bak".

  • Boot on Ubuntu and erase your entire hard drive by writing sudo shred -n 1 -v /dev/sda in a terminal. Make sure you have backups as this will completely nuke your HDD. Once that's done you can reboot on your Windows disc. – André Borie Nov 27 '16 at 11:13
2

Are you sure, your system uses MBR? May be it's GPT?

In Ubuntu as SU check following path: /boot/efi(something like sudo ls /boot/efi/), if it's non-empty, you are, probably, using EFI bootloader.

Way 1: Check out sizes of /boot/efi/EFI/BOOT/BOOTx64.efi and /boot/efi/EFI/grub/grubx64.efi (don't sure about directory, it can be ubuntu, or just linux), if they match -- your system uses fallback bootloader, which is set to GRUB.

From same /boot/efi/EFI folder copy Microsoft/Boot/bootmgfw.efi to BOOT/bootx64.efi replacing it (better make a backup first).

Now your system should boot with Windows bootloader.

Way 2: As su run efibootmgr, if it's not found -- you, probably, are not using EFI. Elsewise it will print current bootloader, boot order and your registered EFI bootloaders. Check out man efibootmgr to set up your bootorder in preferred way.

  • Thank you for your reply @Pavlus . I don't know much about computer. I didn't understand well "In Ubuntu as SU", but I types "su" in the terminal and it is asking me for a password. I don't know what password is asking me to write S: I don't know what MBR or GPT is, but when I did the "fixmbr" thing in the command (blackscreen) it says that the fix was successful. This could mean that my system uses MBR? – Ayrton Lieblos Nov 27 '16 at 23:40
  • No, it doesn't mean anything. If you don't know your Super User password -- use a prefix sudo before a command needed to be executed as Super User, it will ask you your current user's password (su starts a shell with admin privileges, where you can type commands, but sudo executes single command as admin and asks current user password instead of admin password). – Pavlus Nov 28 '16 at 10:30
-1

If you can, reinstall ubuntu, don't overwrite the entire disk, (if your windows 8 partition is still there you'll be ok) then take the steps to make Windows 8 your default bootloader (see How to make Windows bootloader the default?)

Then you can remove Ubuntu's partition if you'd like.

  • EasyBCD is a fairly uncomplicated way of fixing the issue if you manage to get your setup for dual-booting back up again, you should be able to get right back into Windows and fix your setup there. You can if you'd like keep dual-booting with the Windows bootloader where Linux is secondary. If you can't log back into Windows with your dual-booting setup, you may need to look up more in-depth ways to restore the master boot record while you're in Ubuntu (like in the other post) – TheUnknownGeek Dec 2 '16 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.