2

Hi i have this problem for quite some time and I'm unable to solve it. First i noticed this, when windows start showing me error messages "Your computer is low on memory" when usually with the same apps running there were no problems. The longer uptime the worse it gets, so i began to suspect some leak is happening.

This is situation when the system uptime is 9 days (I'm hibernating twice a day, it's hibernated when i sleep and when i'm in work) and everything memory consuming is closed.

http://i.imgur.com/993FRvb.png
(memory usage 40% swap 48%; memory is 8GB swap (pagefile) is 2GB fixed)

http://i.imgur.com/5e9wmzE.png
(paged pool - 397 MB; nonpaged 206 MB; 8GB Ram, 319MB hw reserved (iGPU))

this means used memory is more then 3GB but sum in task manager - process tab is no more then 700 MB.

poolmon screen
(show something with tag fdmg that (if I understand that well) didn't free 2GB of memory.)

so i used findstr -l -m -s fdmg *.sys and got this http://i.imgur.com/0pnHbFs.png

and now, I'm lost, what to do now? My system have some issue, but i don't know where the paged and nonpaged looks ok in task manager, but still, something is eating my memory and not giving it back. What to do? Only reboot helps, but sometimes the memory leaks faster and rebooting every other day is really not solution, and I'd like to avoid reinstalling.

system specs: sandy bridge i3, 8GB ddr3 1333MHz, iGPU HD3000, SSD, 3x HDD, win10 pro x64 upgraded from win7 months ago.

EDIT: It's been some time and it seems to be fine, i had 20 days of uptime (reboot for updates two days ago). I'm not sure wheter I solved the problem or just eliminate it just enough to stop the "low memory" messages. What I did was updating bios to the newest possible (2014 is latest), also some bios tweaks by setting the iGPU memory by hand, although I think It didn't change anything. What I think was the one, switching from Chrome to Vivaldi. Memory is now much more stable, and It's returned when browser is closed. I don't blame the Chrome solely, probably interplay of "unsupported" cpu under win10, hibernating, and that stupid chrome :)

poolmon is now ok, the most eating tag is 160MB and then some in lower tens of MB with Vivaldi running about 80 tabs.

EDIT for duplicity My problem is probably unique by not finding some specific driver causing the leak, instead it looks like Chrome has problem with something. This is still not solved, just symptoms was eliminated for now.

  • open a cmd.exe as admin and run this command: wpr.exe -start CPU -start ReferenceSet -filemode && timeout 5 && wpr.exe -stop C:\HighMemoryUsage.etl. this captures 5 seconds of memory usage, but give me a good start to see more. zip the ETL and share the zip – magicandre1981 Nov 27 '16 at 21:01
  • Have you tried Process Explore from Microsoft (formerly System Internals)? – mbmast Nov 28 '16 at 4:49
  • Windows' " low on memory" message has nothing directly to do with RAM. It's about the commit charge vs. the commit limit. And you can get this message even while seemingly having plenty of free RAM, or even plenty of free commit limit. Remember, you're looking at the system after an allocation request has failed. The fact that the current usage + the request size would exceed the limit is not at all apparent from any display. For more, please see this answer: superuser.com/a/943185/348119 Try setting your pagefile default size to larger, say 8 GB. – Jamie Hanrahan Nov 28 '16 at 13:26
  • @magicandre1981 first thx for edit.... HighMemoryUsage.zip password is lukin download button is upper right corner. One more thing, this log is created when again all memory consuming apps are closed, but i noticed it cleared the ram very hard, somewhere to 14% (1,2GB) but swap remained half full. – Lukin Nov 28 '16 at 17:59
  • 2
    Possible duplicate of Windows 10 Memory Leak – DanHolli Jan 13 '17 at 1:03
1

The high memory usage could be caused by the Intel HD driver. The driver generates modified memory and the system compression compresses it to avoid pagefile usage.

This memory usage leak can be caused if the Intel HD chip has too much memory allocated in BIOS/UEFI. Reduce this number, according to the trace it uses 2300MB. So much memory is not needed for Full HD screen resolution. Set the GPU memory to 256-512MB, this should be enough.

The rest of the memory usage is a sum of your running applications. Reduce the number of running tools at startup if you think your 8GB mmemory is used too much.

  • The only gpu memory setting in bios/uefi is about DVMT 5.0 and I'm not sure if that means anything, but i set it to something like 384 MB (I dont remember :)) I updated bios to the latest. No newer gpu drivers are available and the latest one are only win 7/8/8.1 :/ .. Btw how did u trace up that it was gpu? Where is it visible? On the screenshot the compressed memory is just 266 MB, so is it somehow related to your post about compression memory? – Lukin Nov 29 '16 at 20:55
  • I saw a similar issue some time ago where the DWM also created modified memory and here this memory setting was the issue. Open the ETL with a double click and in the system properties I can that Windows uses 2300MB. And the HD3000 is unsupported in Windows 10 like my HD4000. – magicandre1981 Nov 30 '16 at 5:07
  • Do you mean this? this is current state, it is showing 2364 MB, but now, when I close every memory consuming it's still ok. I rebooted some day ago, current uptime is 24h. GPU-Z show that GPU use ~250 MB. Poolmon now shows something with tag CM31 and findstr can't find anything related to it. It didn't free about 150 MB, but that is ok for now, it might free it later. Also it's the most memory eating tag right now. I'll have to wait for a while if some obvious leek will appear. And fyi, there is HD4000 driver for Win10 – Lukin Nov 30 '16 at 19:13
  • yes, I mean this value. in the release notes PDF of the Intel driver you see this: This driver will not be digitally signed for Windows® 10, which means that it will not have been certified by Microsoft Windows Hardware Quality Labs (WHQL). Note that Windows® 10 may alert you with a message if a driver is not digitally signed, but you can continue the installation. The driver is being provided as-is with no Intel support for any graphics issues found. And your 3000 is even older and here Intel also doesn't fix any issues – magicandre1981 Dec 1 '16 at 5:16
  • But that value doesn't seems to mean actual allocated memory. It's just a guess, but isn't that just some allocable (allocatable?) maximum? I'll probably have to wait some day, until some more leak appears to see if either the new bios or igpu setup help.... Thats kinda sad. – Lukin Dec 1 '16 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.