3

I am dual booting Ubuntu 15.10 and Windows 10. The problem is that the system boots directly into Windows. There is no grub menu shown during startup. In order to boot into Ubuntu I have to press ESC on boot which brings a Startup Menu with the following options:

F1 System Information
F2 System Diagnostics
F9 Boot Device Options
F10 BIOS Setup
F11 System Recovery

ENTER - Continue startup

The above menu is HP specific diagnostic software (I think) which was installed in Windows. On pressing F9 it will bring Boot Option Menu with the following options:

OS boot Manager
ubuntu (....)
Boot From EFI File
Notebook Hard Drive

Choosing ubuntu brings the grub menu with Ubuntu, Windows option. Choose Ubuntu again from grub to boot into Ubuntu. I am on HP e026ax. There is no UEFI. If there is no other OS and just Ubuntu, it will display the grub directly.

Partition Table from gparted:

enter image description here

Of all the Windows partition only two are created by me, the rest are automatically created by Windows and HP.

  • I think you have installed dual OS in dual hard disk correct? – vembutech Nov 28 '16 at 9:55
  • No, there is only one hard disk drive. – user51248 Nov 28 '16 at 10:31
  • Try changing order in bios. Press f10 and go to bios there you can see boot options. I boot options keep Ubuntu first and then try. – vembutech Nov 28 '16 at 10:37
  • There is no ubuntu in boot order. It's just usb, cd, hdd, network. – user51248 Nov 28 '16 at 10:46
0

In your BIOS, check if there's any option for show boot order menu at startup. disable it.

Then from BIOS, change boot order like this:

  Ubuntu (....)
  OS boot Manager
  Boot From EFI File
  Notebook Hard Drive

Then go into Ubuntu.
Open the terminal.

Customize grub

sudo nano /etc/default/grub

It will open file with lot of options. Add this line at the end

 GRUB_SAVEDEFAULT=true    

(This remembers your last choice and boot your last booted OS without your interaction.)

Find line GRUB_HIDDEN_TIMEOUT=0. Place a # symbol at the start of line GRUB_HIDDEN_TIMEOUT=0 in order to turn the line into a comment.

Decrease grub timeout to your preferred value.

Press Ctrl+o and then press Enter to save the changes. Press Ctrl+x to exit nano and type

sudo update-grub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy