0

My Dell XPS 15 doesn't seem to sleep when I close the lid. I'll close it at night and when I open it in the morning the battery will be completely drained. I checked powercfg -requests but all categories show None. Any ideas as to what could be preventing sleep?

  • You will need to check a setting in the Control Panel's power settings to allow the machine to sleep when the lid is closed. – Kaizerwolf Nov 28 '16 at 17:02
  • I checked my power settings and my profile was on High Performance. That explains it, thanks! – Lily Hahn Nov 28 '16 at 19:00
1

For Windows, there is a setting to keep the screen on and the computer awake even when the lid is closed.

This can be changed through the Control Panel -> Power Settings, and either changing the entire power plan to Balanced, or editing the power plan to change the setting for when the lid is closed.

  • I can't believe I didn't check this. Thanks! – Lily Hahn Nov 28 '16 at 19:26
0

XPS 15 7590 in 2019 requires a slightly different approach.

First, you can make sure that your Connected Standby is draining your battery and placing your computer into hibernation:

 # run in admin PowerShell:
 powercfg.exe /systempowerreport /output $home\Desktop\power-report.html
 # open in browser:
 file:///C:/Users/YOURUSERNAME/Desktop/power-report.html

If you see "Drain (dozed to hibernate because the standby battery budget was exceeded)", then the following can help.

Normally, you would turn off Connected Standby altogether by setting HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power CsEnabled = 0, but due to an issue with the WiFi/Bluetooth adapter, you will completely lose Bluetooth on every wake up.

This worked for me (in the context of Connected Standby):

  1. Go to Windows Settings -> Power & Sleep -> Network Connection -> Disconnect from the network -> Always

  2. Open an admin PowerShell and run (you must have Chocolatey installed; alternatively you can install NSudo manually):

    choco install -y nsudo
    
  3. Open a new PowerShell window without restrictions:

    nsudo -U:S -P:E powershell
    
  4. In that window, disable tasks which torture your computer when you leave it idle for a few minutes:

    Get-ScheduledTask | Where-Object { $_.State -ne "Disabled" -and $_.Triggers -match "MSFT_TaskIdleTrigger"} | Disable-ScheduledTask
    
  5. Disable tasks which deplete your battery in Connected Standby, placing your computer in hibernation, and severely slowing the next startup when you open the lid:

    Get-ScheduledTask | Where-Object { $_.State -ne "Disabled" -and $_.settings.waketorun } | Disable-ScheduledTask
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.