7

I have a Windows 10 PC in my car that I use as a head unit for the audio system, and I'm having trouble with background noise. I have been able to detect it on another Windows 10 PC as well. The noise is NOT interference on the analog output. It must be of a software origin because I used Audacity to record the WASAPI output when nothing was playing, and sure enough the noise is there.

To clarify: the following noise samples are recorded using software only. This is not what plays from the analog output of the DAC; this is what Windows sends to the DAC.

I have recorded it from the Speakers output as well as VB Audio virtual cable output (I absolutely need the virtual cable). Interestingly, the spectrum is a bit different, but the noise is similar on both outputs.

Here are short unamplified noise samples exactly as recorded by Audacity - no tampering:

These are 16-bit recordings, so the sample value range is from -32768 to +32767. The noise is -8 to +8 peak to peak, with roughly -4 to +4 average. Here's the waveform and spectrum of the noise:

enter image description here

What can possibly be producing this noise and how to get rid of it or at least reduce it? It may seem too quiet to be a problem, and I never heard it through headphones, but in the car where there's a good set of speakers and some amplification it can be heard quite distinctly when nothing is playing.

I can also confirm that this noise I recorded on a different PC indeed matches the feel and the character of the noise I hear in my car.

Can someone with Windows 10 download Audacity and capture their audio output in order to find out how common or uncommon this problem is?

UPDATE: I have repeated the experiment on my home laptop and desktop computers, both Win 10 as well, and have confirmed the issue there as well. All the samples I collected on these 2 systems are exactly the same, unlike my office desktop where they differ in noise spectrum a bit.

UPDATE 2: Important new findings: 1. I can hear this noise quite clearly with my home laptop via EMU 0404 USB DAC -> 35W @ 4 Ohm amp -> shelf speakers. I need to set the amp's volume to max and I can hear it then. The system becomes dead quiet when I turn the DAC off. 2. I have run a proper spectrum analysis on the noise. While its amplitude is only 8, which is -78 dB in 16 bits, but its spectrum reaches as high up as -30 dB. That explains why I can hear it: -30 is a clearly audible quiet sound on any decent system, and -40 is still audible when you sit close to the speakers (which you always do in a car, incidentally). Also, my car amp is 60W @ 4 Ohm so its gain is higher than that of my home amp (and then there's also a matter of the tweeter's sensitivity which differs for different models).

enter image description here

  • 1
    Comments are not for extended discussion; this conversation has been moved to chat. – Mokubai Dec 3 '16 at 10:33
  • Can you replicate the unwanted noise in the recording while your soundcard is disabled via Device Manager in Windows? I realize you're recording what Windows sends to the DAC but I'm curious what you get when no 3rd party audio software (i.e. soundcard driver) is active. – Twisty Impersonator Dec 3 '16 at 20:34
  • 1
    @fixer1234: I'm an engineer, I know how this works. And I'm telling for the 10th time that the operating system or something within it produces noise even before any analog conversion occurs. And numbers do very well translate to noise. See the spectrum above. – Violet Giraffe Dec 5 '16 at 8:24
  • 1
    @mlvljr: Yep, I noticed that bit in the description. But since it didn't work properly when I played some music I can't call the experiment definitive. – Violet Giraffe Dec 6 '16 at 10:55
  • 1
    Let us continue this discussion in chat. – mlvljr Dec 6 '16 at 11:13
4
+50

In case you haven't already, ensure all inputs have been disabled and are not part of the mix you are recording. Just because you are recording what is being sent to the DAC, doesn't mean Windows hasn't already mixed in some electrical noise on an input. In fact, I would disable the input completely and lower the recording volume on the mix to zero.

To determine if the issue is hardware or driver related, I would install a different OS on a temporary drive, or boot from a USB key (https://www.ubuntu.com/download/desktop/create-a-usb-stick-on-windows).

If the problem goes away then it is a driver issue and you may have a chance of fixing it by manually installing an different driver version, or even a generic one if it exists. There is still a small possibility that it's a hardware bug uncovered by a driver-specific feature.

If the problem persists then it's quite likely a hardware bug. I would still check where in the boot process the noise starts (power on, after hardware init and POST, during OS bootup, after the first OS sound plays, after application start). If it's after the OS starts then you may have some luck with drivers. If it's before OS startup, then there is likely not much you can do, save for a firmware update.

Good luck!

Update 1

I have recreated your results using the following steps:

  • Record the speaker output using WASAPI
  • Export the file to a WAV file
  • Open the saved file
  • Amplify +50db

The result is a significant amount of noise and the spectrum analysis has the same shape as yours.

I have also recreated the result using these steps:

  • Generate 30s of silence in Audacity
  • Export the file to a WAV file
  • Open the saved file
  • Amplify +50db

Conclusion: The sound you see is generated by the algorithm that saves the file. The sound you hear is generated elsewhere, probably typical line noise.

As proof, try recording your speaker output and before saving apply amplification. If you are using the latest Audacity you will get a value overflow error b/c it can't handle amplifying complete silence. If you have at least one non-zero value in the selection, the amplification works.

Update 2

Further proof: Try saving your recording as 64 bit raw data, and then importing it again. For me this results in a file with no noise, that cannot be amplified again.

  • You said you "used Audacity to record the WASAPI output when nothing was playing, and sure enough the noise is there". This could mean that one of the inputs (ex: microphone) is mixed in all the time (i.e. playing through). If you have a mic or line input on the system this is easily possible. – Jens Ehrich Dec 8 '16 at 18:31
  • There's rarely a mic, but there is a line input on every system I tested, although usually unplugged. Anyway, I have disabled all the inputs, and nothing changed. That's not it. – Violet Giraffe Dec 9 '16 at 7:49
  • Here is a similar recording on my T430s that has a Realtek High Definition audio chip: drive.google.com/open?id=0Byx7IqrfztmcQ2ZOR3hCb1V1Q2M. Recorded the speaker output using WASAPI in the latest Audacity portable. The file shows no sign of noise even when normalized to -1 db. This is a nearly fresh install of the latest Win10 LTSB and my current driver is v6.0.1.7614 from 2015-09-15 by Realtek Semiconductor Corp. I suggest trying to boot from a fresh/different OS instance to eliminate any installed software that might be causing this. – Jens Ehrich Dec 9 '16 at 14:56
  • The noise is right there. You're making the same mistake as other commenters of not using the right tools: i.imgur.com/fWnaM8I.png Hint: open this WAV in Audacity and apply +48 dB amplification. – Violet Giraffe Dec 9 '16 at 15:05
  • 2
    The noise is probably introduced during the conversion to 16-bit at some point in the digital path, as it was with saving the file. This is either an implementation bug in the conversion algorithm (0 should always round to 0 IMO) or a side effect of dithering (en.wikipedia.org/wiki/Audio_bit_depth). If you can find the offending conversion you may be able to omit it or change to 32-bit processing. To test this theory, try playing a 32-bit WAV file in the car without any processing. – Jens Ehrich Dec 9 '16 at 16:51
0

It seems like this is a common problem for people using RealTek cards, often built into the motherboard (source)

Solutions tend to be

  • get another sound card by a different manufacturer
  • disable "PC Beep" (source 2)

(yes, I read that you are looking for a windows software problem rather than hardware. I'm assuming that the RealTek problems lie in the software driver.)

  • That is strange. And while those sources say what... I'm curious to the why... – Journeyman Geek Dec 8 '16 at 5:35
  • Actually, only half the PCs I tested use a Realtek codec. The target PC where this is a noticeable problem uses ODAC USB sound card and doesn't even have a Realtek sound chip (there is a built-in codec, but it's from a different manufacturer). And my home laptop uses Creative EMU 0404 USB interface (but does have a Realtek built-in). – Violet Giraffe Dec 8 '16 at 5:47
-1

If you are using HDMI or ANY other form of digital sound output, what you could be hearing is the keep alive between the system and the digital receiver in the speaker to convert between the digital signal to analog for the speaker. For you vehicle situation, I would recommend running a RPI as the integrated solution to avoid similar issues. As for the desktops, I'm willing to bet that you leave your speakers turned all the way up and use the system for volume control. In this case, the sound you hear is a mixture of system keep alive if digital and input power to the speaker. The same idea for a guitar amp that is turned up all the way with nothing plugged in, you can still hear a kind of static noise. So turn your speakers down a bit (75%) and use their manual control for volume change. Once you have optimized the soumd level / quality that the computers are transmitting at, you can find the area that the speakers are the loudest at/ don't talk to you and play from there. It's really a game of playing the two systems to get the best quality without overdoing your transmitting power, and your amplified power on the speaker. If you overdo one, you will get the effect you describe in your sound clips.

  • It's not HDMI in my car, it's a USB DAC (one that uses a standard protocol and requires no driver). And the other 3 systems use the built-in Realtek codec – Violet Giraffe Dec 2 '16 at 8:18
  • 1
    Unfortunately, you didn't read read my question carefully, especially the part where I explain that the noise occurs even before any analog conversions. I have successfully recorded the noise PROGRAMMATICALLY. It's not what the DAC plays, it's what Windows send to the DAC. – Violet Giraffe Dec 2 '16 at 8:19
-1

It's not the windows sending you sounds , but ur sound card ,audacity makes a loop back from the output from the sound card , not from just windows , make sure all your computers are properly earthed . Check it with an electrician , I also had the same problem . I fixed it by properly earthing all the devices , and check your laptop is giving the same sound when it's working on battery. I downloaded audacity and checked my sound output and there were no problem. I'm also using windows 10 . Hope this helped.

  • What you say would be true if I took a piece of analog cable to physically loop the signal from analog output to analog input, but that's not what I did. Audacity's loopback is software, not hardware. Grounding has nothing to do with this. Also, you probably didn't use the right tools to analyze the recording you made. Could you send it to me? As I said, it happens on 4 out of 4 different computers I tested it with, so I can bet it happens on your system as well. – Violet Giraffe Dec 2 '16 at 11:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.