When trying to install Greenshot on fresh copy of Windows 10, the following error occurs

enter image description here

Please, note that the question is about Windows-10. Questions about Windows-7 and below are not "duplicate".


How to install Greenshot so that PrintScreen work?

  • 1
    I don't see a question here. The message displayed is a warning, not an error message, and seems pretty self-explanatory.
    – kreemoweet
    Nov 29 '16 at 17:33
  • Download the ZIP file of Greenshot (no installer) from GitHub:: github.com/greenshot/greenshot/releases and extract all files to run Greenshot.exe
    – Biswapriyo
    Aug 11 '17 at 13:33

On a new PC, press printscreen and the first time OneDrive pops up and offers you to save screenshots. Select No and the key will be free for Greenshot.

  • 6
    Ctrl-PrintScreen seems to be commandeered by DropBox, in case any future readers see this. The same advice applies from @userJT Oct 13 '18 at 14:55
  • Same thing here: Dropbox was blocking the Printscreen button. Pressed "Printscreen", clicked "No thanks" and then "Retry" on Greenshot. Everything works fine now!
    – Ariel
    Dec 21 '19 at 18:05

Greenshot cannot register the desired hotykey (PrntScreen) if another program has already registered it, that's why it gives you that warning message.

If you want Greenshot to work with the PrntScreen, you need to find out which program is blocking the hotkey, it is most likely either OneNote or DropBox. Configure them not to use the PrntScreen hotkey, and restart Greenshot. Read more here: http://getgreenshot.org/faq/my-prntscreen-key-no-longer-works-with-greenshot/

In case you want to use Greenshot but still don't want to turn off that specific feature of OneNote or Dropbox, another alternative would be to change Greenshot's hotkey, you can easily do so in Greenshot's settings dialog.

  • 2
    It was DropBox for me.
    – Chris
    Aug 23 '17 at 20:41
  • 1
    This is the answer. Was OneDrive for me, but it could be any other program which is hogging the printscreen button.
    – Daniel
    Jun 23 '18 at 12:35
  • 1
    Still unable in Win 10 Pro. I never saw a dialog from Greenshot having trouble, nor a setting or dialog in OneDrive. I have it unchecked in Dropbox, and do not have EvernoteHelper. I have OOSU10 and played with the OneDrive setting in there, thought it may have helped, but Greenshot still seems to want focus before the hotkey works again.. I noticed it does work more generally now, but not with an install program and others like OOSU10 currently focused...
    – Pysis
    Jul 14 '18 at 16:32
  • 1
    @Pysis not sure wether this is still relevant, but the problem you describe is a different one. If the currently focused window is running with admin privileges, Windows does not send hotkey notifications to programs running without. A possible solution would be to run Greenshot with admin privileges. See here: getgreenshot.org/faq/…
    – jklingen
    Jan 6 '19 at 18:55
  • 1
    That may be a good point, and would clear up the intermittent nature of the error. I was just having the problem recently the other day, until I simply left clicked Greenshot in the tray, then pressed the hotkey, or unfocused and pressed, then it worked.
    – Pysis
    Jan 9 '19 at 22:28

Adding on top of @userJT's solution -

Initially, Greenshot complained about "PrintScreen" and "Ctrl + PrintScreen" for me. It appears that "PrintScreen" was taken by OneDrive and "Ctrl + PrintScreen" - by DropBox. After you disable both, problem goes away.

Full list of steps -

  1. See the error message like in the question. Panic, google, get to this page :)
  2. Note the first key that Greenshot complains about.
    • In most of the cases it will be "PrintScreen", so let's take it as an example.
  3. Press "PrintScreen" on your keyboard.
  4. OneDrive will pop up, prompting to save screenshots to OneDrive. Choose "No, Thanks" there.
  5. Click "Retry" in Greenshot's dialog, note the keys that are still taken.
  6. Repeat steps above for keys that Greenshot cannot register until it succeeds.
    • In my case it was "Ctrl + PrintScreen" that was taken by DropBox.
  7. Enjoy shortcuts in Greenshot :)



Try this:

Launch Powershell as admin (Start > type Powershell > Right click Run as admin)
Copy and paste the following

New-ItemProperty -Path "HKCU:\Control Panel\Keyboard" -Name PrintScreenKeyForSnippingEnabled -PropertyType DWord -Value 0 -Force

I noticed this line whiz past when running a Windows 10 debloat script. (it enabled the option)
I read through the script, found the line and reran with it set to "0"


I encountered the same warning message about the hot keys.
My solution (Windows 10):

  1. Go to "Settings" > "Ease of Access" > "Keyboard".
  2. Turn off Print Screen shortcut 'Use the PrtScn button to open screen snipping'. I think this disables the standard program using the hotkey
  3. Now, the PrntScn button works with Greenshot.

Hope this helps :)


1- Windows 10 start bar dialog: Go to "Settings" > "Ease of Access" > "Keyboard".

2- Turn off 'Use the PrtScn button to open screen snipping'. (this disables the standard program using the hotkey)

3- Reconfigure PrtScn button inside Greenshot Preferences. Now it works! =)


Just try pressing the PRTSCR key without the FN key. That works for me now since a recent windows 10 update

  • 2
    How is that supposed to answer the question?
    – RalfFriedl
    Oct 9 '19 at 16:51
  • This doesn't answer the OP's question - although the OP's question isn't very clear.
    – Glenn
    Oct 9 '19 at 18:37

I had the same problem and non of the solutions above worked. I found this link on the Greenshot web


Just follow the instructions on how to edit your greenshot.ini file. Change the following line: RegionHotkey=None

To be this: RegionHotkey=PrintScreen

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.