1

If I have a CSV file like this:

Id,Name,Reference
1,Alice,123EFG
2,Bob,456E89
3,Charles,7E9K2M
4,Donald,12345678E28496023749

and I open it in LibreOffice, some of the values are converted to scientific notation, like this:

screenshot from LibreOffice

Note that this is not just how the value is formatted for display. You can see from the formula box that actual value has been changed to scientific notation, so there is no way within LibreOffice at this point to recover the data that has been lost in this conversion.

How can I open the file in LibreOffice without these values being converted to scientific notation?

4

Try these options in the Text Import dialog:

  1. Deselect the 'Detect Special Numbers' checkbox
  2. In the preview area, click the column header where it is labeled 'Standard' and change it to 'Text'. According to the documentation:
    • Standard: LibreOffice determines the type.
    • Text: Imported data are treated as text.

enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.