I have recently bought a Raspberry Pi Zero (RPi), and now I'm trying to get it connected via ssh to my pc (using the program putty).

I have two laptops, both from HP and both running (very close to) the newest Windows 10 version:

  • HP Pavilion 17-ab002nb, from now on laptop A
  • HP ProBook 4730s, laptop B

I installed the necessary stuff on the RPi, and when I plug it in laptop A it shows up in the device manager under Network Adapters as USB Ethernet/RNDIS Gadget #2:

enter image description here

The installed driver looks like this:

enter image description here

And I can simply connect with the RPi over ssh, using the address raspberrypi.local.

When I connect it to laptop B I get a completely different result though, the RPi shows up under Ports (COM & LPT) as Serial USB Device (COM6):

enter image description here

With driver details:

enter image description here

This is wrong, the RPi should not be recognised as a Serial device. I asked in the freenode#raspberrypi IRC channel and they confirmed that my RPi is set up correctly.

I tried copying the driver from laptop A to laptop B and installing it from within the Device Manager, but it didn't work:

enter image description here

Is there a way to force Windows to install the correct driver?

Edit: As requested, a screenshot of the device manager on Devices by connection view. I'm not sure where I can find the device ID, but I added the device locations of a couple of "interesting" devices in the image: enter image description here

Edit 2: The Hardware Ids for the Serial device (on laptop B):


The same Ids on laptop A:


They are indeed exactly the same.

  • Very unlikely. The "unknown device"s are much more interesting. Switch to" By connection" view to verify what is what. Also, compare device IDs in the devices' properties.
    – Daniel B
    Nov 29, 2016 at 23:11
  • Which device is running a 32-bit version of Windows?
    – Ramhound
    Nov 30, 2016 at 0:14
  • @Ramhound I believe they're both running a 64-bit version. Nov 30, 2016 at 0:20
  • @DanielB I edited my question to supply the additional information you requested. Nov 30, 2016 at 14:37
  • 1
    It might be a power thing : USB 3 has higher maximum current than USB 2 (950 mA vs. 500). Otherwise there are too many possibilities in RPi hardware or its USB driver for me to give an answer.
    – harrymc
    Dec 3, 2016 at 21:34

1 Answer 1


In answer to my question in the comments above, it turns out that the Raspberry Pi Zero (RPi) works with a USB-3 port but not with USB-2.

In a new development, the poster reported that the RPi started working after he installed a USB3 driver on the computer, even though that computer does not have a USB3 port. I counseled using Driver Magician Lite for the backup of the driver from laptop A, then using Device Manager to install it manually on B. I am still surprised myself that this long shot did work after all, but kudos to the poster that suggested it first.

Old answer

Below are some conjectures and further tests that might pinpoint the problem.

  1. Power : USB3 has higher maximum current than USB2 (950 mA vs. 500).
    According to reports, the RPi uses less than 500 mA, but power consumption can vary by the number of peripherals attached. In addition, USB port power is unreliable and can sometimes temporarily sag, which is certainly less noticeable on 950 mA than 500.
    What you can do as test is :

    1. Try a self-powered USB hub for more constant power.
    2. Disengage all attached RPi peripherals
    3. Try on another computer, preferably a desktop
    4. Conserve power and reduce draw : Disable HDMI - 25mA, Disable LEDs - 5mA per LED, disable software : 100+ mA.
  2. Hardware problem : The RPi is the king of cut-priced hardware, but I never heard of a USB3 controller that couldn't also do USB2. So I judge this as a very unlikely possibility, for which there is in any case no remedy. You could try a better-quality USB cable, in case of incompatibility.

  3. Firmware problem : This is Raspbian, a flavor of Linux. A problem here means protocol troubles for the driver, since the USB3 protocol does differ from USB2 on points such as polling, transmitting without prompt and more. I don't know which software repository is used by Raspbian, but maybe a newer USB driver exists in it.

  • First of all, thanks for answering my question! I don't have a self-powered hub, so I tried plugging a phone charger in to the dedicated power usb port on the RPi, but that didn't change anything. There are no peripherals connected to the RPi, and I still have to try the other ways to conserve power. Dec 4, 2016 at 22:38
  • The cable I'm using should be good, I have used it for lots of other stuff in the past. When I installed Ubuntu on laptop B the RPi is recognised as an ethernet device, so I still think it's a problem within Windows. Dec 4, 2016 at 22:40
  • It's entirely possible that it's a usb2 communication problem between the Windows and RPi drivers. Another test: Try the RPi on a Windows computer that has both kinds of ports but connect it to a usb2 port (a computer with a usb3 driver may better handle usb3 on usb2 port). Tests on other computers will be useful. Have you tried using Windows 10 (best device detection)? Try also Linux - if you don't have a computer with Linux you could boot from a live CD/USB.
    – harrymc
    Dec 5, 2016 at 6:54
  • 1
    Laptop A actually has a USB 2 port, and the RPi works just fine in that one. As I said in my previous comment, Ubuntu (on laptop B) recognizes the RPi as an Ethernet adapter, though I haven't been able to get ssh to work there. Both laptop A and B are running Windows 10. I don't have access to more computers, so unfortunately I can't do much more tests. Is there any other way I can try to debug this issue? Dec 5, 2016 at 21:58
  • That's interesting. If logic can apply to Windows, we are left with 2 alternatives: (1) Some hardware incompatibility on this one computer and port, (2) Missing driver. For the second, try to install the usb3 driver from the computer that works even if the target has no usb3 ports. For the first, there isn't much to be done.
    – harrymc
    Dec 6, 2016 at 6:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .