11

I was about to visit a site on Chrome and found the following message displayed:

Clock

The same site opens up in Firefox without any problem. This makes me believe the issue is browser-specific. What does this mean? The server time is behind my local time? And if so, why would Chrome not allow me to view the page.

Or is this something that the developer of the website coded into his page as a condition?

Btw, the clock time is perfectly fine. I've not moved it ahead by x hours/minutes.

4
  • 2
    Secure connections have a timeout value, and probably a few other time-related properties. If the time on your computer is different from real time then your connection will be timed out before it can be connected or you can't connect at all
    – phuclv
    Nov 30 '16 at 8:41
  • Two people cross a road without looking both ways. One gets hit by a bus, the other doesn't. Does this show that getting hit by a bus when crossing the road without looking both ways is person-specific? Maybe you just only get hit sometimes. Jun 22 '17 at 8:02
  • @LưuVĩnhPhúc but how come firefox works then? Chrome's job is to display the website. I'm stuck with firefox as I don't have enough privileges to fix the time. Jan 24 '18 at 9:10
  • @ClaudiuCreanga no idea. You may try adding a bounty or ask a related question
    – phuclv
    Jan 24 '18 at 16:37
2

My view on the answer is simply that the two browsers are built differently and their error checking works in different ways. Furthermore, they have different default settings and the settings on either browser may have been changed at some point which influences how they work. You're effectively saying, here's two programs, they do similar jobs but why do they work differently?

As you've seen yourself, Chrome will throw an error that your system clock time is incorrect if it thinks it's not matching up: this creates an SSL error where Chrome will notify you, the user if it thinks something dodgy is going on. It's one step in a process of SSL checking to ensure you're kept as safe as possible. It's extremely unlikely that it's related to the coding of the webpage itself, website developers usually want to make their websites as accessible as possible to everyone, and this is also a known Chrome error.

Firefox has it's own version which pops up from time to time for (apparently) similar reasons:

enter image description here

So there's a few reasons why the two act differently:

  • When you write a program that uses the time set in the host system, there are different ways of getting this time. You could call the variable System.currentTime or clock in Java which are all slightly different things. If you're working in C++ you could call std::chrono::system_clock::now() or std::clock or std::chrono::high_resolution_clock which again aren't the same variables. It all depends on how you want to build the program. So firstly, it's possible that Firefox or Chrome are calling a different time variable. Why would the variables be different? Windows is well documented for it's troubles in trying to get it's times, timezones, daylight saving etc all correct! Your system settings can affect whether these update automatically or manually and so on, and therefore you can get discrepancies.

  • There's also evidence that both Chrome and Firefox can get things wrong sometimes too. Some queries on their forums show users with correct system times but with Chrome and Firefox constantly giving them errors related to incorrect time settings. This could be a bug, some incorrect settings or pretty much anything else!

  • There's also settings in both Chrome and Firefox to turn off the settings that check the SSL. You can turn off HTTPS scanning, or edit security settings to not show security warnings.

  • THIS ISN'T RECOMMENDED! But as an example, in chrome type chrome://flags in the address bar and press Enter. Then type the word “secure” in the search box at the top to make it easier to find the setting we need. Scroll down to the Mark non-secure origins as non-secure setting and change it to “Disabled” to turn off the “Not Secure” warnings. Scroll down to the Allow invalid certificates for resources loaded from localhost setting and change it to “Disabled” to turn off any SSL warnings.

  • You will see in the example above that there are a lot of other security settings that can be changed, Firefox also has a large range of settings.

In summary, I'm not sure if there's a definitive answer to your question without doing a lot of testing. It might depend on the programs themselves, it might depend on the settings of your system, it could be caused by a bug or error and so on. I hope I've helped to show why there's not a definitive answer though!

1
  • Thanks. Detailed answer good enough.
    – asprin
    Oct 20 '20 at 7:10
-1

The certificate is expired last couple of times I got this. Does it let you set an exception - Android verion won't let me so the only other way was to set "--ignore-certificate-errors" in the command line.

1
  • 1
    But OP is using Windows 8 and probably the time settings are not accurate
    – Sam
    Jun 22 '17 at 8:08
-4

If you click on the advanced link, you will get your answer. It says something to the effect that it cannot verify the validity of security certificates without the proper date/time.

1
  • 4
    Please explain why the proper date and time is needed and how it works in chrome and maybe in firefox.Please do not only refer to a button or link, you must explain it in your answer.
    – testeaxeax
    Aug 5 '17 at 16:02
-6

"Your clock is behind" or "Your clock is ahead" or "NET::ERR_CERT_DATE_INVALID" You'll see this error if your computer or mobile device's date and time are inaccurate.

To fix the error, open your device's clock and make sure the time and date are correct or go this link https://www.youtube.com/watch?v=-qhwtXoRmHc

2
  • 2
    I understand what needs to be done in order to fix it. What I'm looking for is the reason why Chrome won't allow me to view the website while Firefox does. It does seem to be client-side rather than server side.
    – asprin
    Nov 30 '16 at 10:52
  • 1
    did you cleared your chrome browser cookies and caches.....?
    – vijay
    Nov 30 '16 at 11:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.