5

I have installed elementary OS Loki on my system and everything works fantastic but the only problem is bluetooth.I had windows 10 installed on my system earlier but I formatted it and installed fresh copy of elementary os. So my problem is that I can open the bluetooth menu and when I click to add new device, it just keeps on searching, it doesn't find any device.

1
5

The only thing that worked on my Lenovo G575 was installing blueman:

sudo apt-get install blueman
0
0

Check this one out. Solved my problems with a Broadcom bluetooth device. https://medium.com/@sujeetb/how-i-fixed-my-bluetooth-issue-in-ubuntu-18-04-lts-805c865fa87 The lack of bluetooth functionality has been the final show stopper for me this far and now it's gone :)

In case the link dies some time in the future, here is the contents carbon copied (well, fixed a few minor typos), thanks to Sujeet Buddiga, the original author. Note that in 3) and on, you will have to use the proper string (brcm/xxx.hcd) you found in 2) to get the right result.

  1. Run the following command on the terminal:

dmesg | grep brcm

  1. If this is a broadcom driver issue. it will show something like: brcm/BCM43142A0–0a5c-21d7.hcd not found.

  2. Copy BCM43142A0–0a5c-21d7.hcd on google, you will end up finding a link like this: https://github.com/winterheart/broadcom-bt-firmware/blob/master/brcm/BCM43142A0-0a5c-21d7.hcd

  3. Download it

  4. Copy it to the /lib/firmware/brcm folder

  5. Restart the System

  6. Turn Off and Turn On Bluetooth

0

In my case I didn't modify anything. Just turn off the secure boot in BIOS, Bluetooth and all other issues will go away. Everything will start working smoothly. If you did dualboot with other OS and you switch over to other and back to Elementary OS then your Bluetooth is not gonna work. Just stick with one OS. If in case you had to switch to other OS, then just go to BIOS and switch on the secure boot and again turn it off and save the settings and boot to Elementary OS. Again your Bluetooth will start working again.

0

After days of struggling with this issue, I finally got the bluetooth capability on Elementary OS Hera to work by updating bluez to the latest version. I also deleted the Windows OS partition as well as I no longer have a need for it.

Here are the instructions I followed: https://launchpad.net/~bluetooth/+archive/ubuntu/bluez.

2
  • The info in the site may change over time or the site may go down. In order to help other users you should briefly describe every step here and provide the link just for reference.
    – ZygD
    Mar 14 '21 at 8:37
  • Welcome to Super User! Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Mar 15 '21 at 16:57
0

My Elementary Loki couldn't find the Bluetooth devices, even though the devices's pairing switch was on.

In short, I tried following process.

sudo nano /etc/bluetooth/main.conf

Change #AutoEnable=false to AutoEnable=true (at the bottom of the file, by default)

After that:

sudo service /etc/init.d/bluetooth restart

Then my elementary machine was able to find the Bluetooth devices.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.