5

I can toggle between languages but can't change the Input Method to Kanji, Kana or Katakana.

All tutorials and instructions says that after selecting Japanese Microsoft IME you only need to click on the "A" to toggle between Romaji/Kanji/Kana/Katakana or use one of many keyboard shortcuts, but they do nothing. If you right click on it to see all the options it's all in japanese and any change you make neither gets applied or saved (you may open the context menu again and everything will be just as before).

If you try to go to Settings->Time and Language->Region and Language->Japanese (Options)->Microsoft IME (Options) the Metro App WILL CRASH and close.

This is the same for the non-metro Control Panel. Control Panel->Language->Japanese (Options)->Microsoft IME (Options) and a window will open and close immediately.

The Metro App is the only one that registers an Error Event on the Event Viewer

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2016-11-30T23:52:56.199552100Z" />
    <EventRecordID>11396</EventRecordID>
    <Channel>Application</Channel>
    <Computer>*******</Computer>
    <Security />
</System>
<EventData>
    <Data>SystemSettings.exe</Data>
    <Data>10.0.14393.82</Data>
    <Data>57a55dc6</Data>
    <Data>Windows.UI.Xaml.dll</Data>
    <Data>10.0.14393.351</Data>
    <Data>5801a795</Data>
    <Data>c000027b</Data>
    <Data>00000000006d714b</Data>
    <Data>c20</Data>
    <Data>01d24b64d2be345c</Data>
    <Data>C:\WINDOWS\ImmersiveControlPanel\SystemSettings.exe</Data>
    <Data>C:\Windows\System32\Windows.UI.Xaml.dll</Data>
    <Data>a94b04f8-b8d2-42f5-9a6f-8b79434abaf1</Data>
    <Data>windows.immersivecontrolpanel_6.2.0.0_neutral_neutral_cw5n1h2txyewy</Data>
    <Data>microsoft.windows.immersivecontrolpanel</Data>
</EventData>
</Event>

Windows Edition: Windows 10 Home Single Language (it may be this?)

Version: 1607

Build: 14393.447

  • 1
    I had a similar problem for which the solution did not work. I'm not sure whether it was a setting imposed from the administrator (work laptop), but it just won't allow me to type in hiragana. I resorted to installing Google's Japanese IME, which so far I've seen works the same as the Window's one. – Jerry Sep 2 '19 at 18:01
3

After hours of trying to figure this out and an unfruitful search on Google I found a way to get the advanced settings menu to come up and the language selection style menu to stay in English. Properties works now. I have verified this one two of the Windows 10 Home machines I have.

  1. Start Menu > Search > Event Viewer
  2. Open Event Viewer
  3. Select "Japanese Microsoft IME" (Windows key + Spacebar)
  4. Click on "A" on taskbar
  5. Now it should change from "A" to "Kanji/Kana" and if you Right click on the "A" or "Kanji" the menu should show up in English. Make sure your active window is the "Event Viewer" or the menu may revert back to Japanese characters.
  6. In English menu on the taskbar, select "Properties" > Advanced > General Tab > Input settings/input method: Kana Input, click Apply Conversion Tab > Include in candidate list Half-width Katakana and Romaji, click Apply

Just to make sure all settings are correct, the Microsoft Advanced Options page should now work.

  1. Select "Language Preferences" (Windows key + Spacebar)
  2. Select the Japanese Language > Options
  3. Under Keyboards > Microsoft IME > Options > Verify Radio button is OFF for Use Kana Input Open Advanced Settings (all the way at the bottom of menu)

Close out Notepad if you have it open. Re-Open notepad. Select Japanese Microsoft IME language again (if not already done) and change to Kanji characters. Type something to test.

I had an issue where OneNote that I was testing in would not work. It was not until the changes were made and I restarted Onenote did it finally start working within Onenote.

I hope this work-around works for everyone. I have restarted Windows multiple times and the changes stayed.

| improve this answer | |
  • 1
    This worked but I didn't understand that about Turning OFF the Radio Button for "Use Kana Input Open Advanced Settings", in Advanced Settings I couldn't find any radio button about Kana Input. What I did, was to change the Input Method from the General Tab back to "Romaji Input" – Sdlion Jan 31 '17 at 19:39
  • Doesn't work here. I tried everything in this thread, where the above also appeared. – Kaz Jan 17 at 22:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.