1

I'm currently trying setup a penetration testing lab on two machines. One machine will run the vulnerable virtual machines and the other machine will be used as the attack machine running different software and OS's.

I'm trying to connect these machines through there NIC controllers.

Both computers are using windows 10 I have already statically assigned both pc's with ip address withing the same subnet and same mask but am unable to ping each other. Network Layout

  • Are you using a crossover cable to connect the two PCs? – n8te Dec 1 '16 at 3:44
  • MDI-X allows for this to be done using a straight cable connection – Mrose814 Dec 1 '16 at 3:59
  • What did you set the gateway as on both PCs? – n8te Dec 1 '16 at 4:11
  • Okay so the solution was found, The Ethernet controller was settling the connection to no discover new networks and had sharing turned off. Banged my head against this for 4 hours. Easy fix I looked over – Mrose814 Dec 1 '16 at 4:12
  • Ahh ok. If you got a sec, go ahead and create an answer with that info so people will be able to reference this in the future. – n8te Dec 1 '16 at 4:13
0

Assuming that everything you say is correct; you've verified both static IPs are on the same subnet, with the same mask, and you have lights on both NICs, then the only explanation would be that the firewalls are blocking each other.

0

I have my penetration lab up and running and wanted to give some details for other people that might run into this problem using windows:

  1. Static Ip assigned: Control Panel >Network and Internet > Network Sharing > Change Adapter Settings > Right Click the Port being used and select properties > IPV4

  2. Repeat step 1 for second machine make sure both assigned IPs are within the same subnet and have the same mask.

  3. Sharing Options: Control Panel >Network and Internet > Network Sharing > Change advance Sharing Settings > Turn on network discovery.

Continue these settings for any virtual machine you setup on your penetration lab. Use bridge connection and allow all machines promiscuous mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.