2

I have some problem with the micro SD card I usually use on my phone. I recently updated my phone to Android 6 and it is now asking me to format the SC card.
However it always fails.

I tried to format it in the computer (Windows 10), using a cheap USB stick adaptor. Quick format fails and complete format fails at the end after more than two hours running.

I tried EaseUS Partition Manager to format the card, but had a similar result:

There are some error occurred while writing partition chains on disk.

A Google search pointed me to the testdisk utility, which gave me the following message:

Current partition structure:  
check_FAT: Unusual media descriptor (0xf0!=0xf8)  
Warning: number of heads/cylinder mismatches 4 (FAT) != 255 (HD)  
Warning: number of sectors per track mismatches 16 (FAT) != 63 (HD)  
   P FAT32                    0   0  1  3852 194 54   61894656 [NO NAME]

On Linux (I'm not an advanced user), the system detects the card but cannot mount it. dmesg gives me the following information:

[  146.356105] usb 1-5.3: new high-speed USB device number 3 using ehci-pci  
[  146.443845] usb 1-5.3: New USB device found, idVendor=058f, idProduct=6335  
[  146.443850] usb 1-5.3: New USB device strings: Mfr=1, Product=2,  SerialNumber=3 
[  146.443853] usb 1-5.3: Product: Mass Storage Device  
[  146.443856] usb 1-5.3: Manufacturer: Generic  
[  146.443858] usb 1-5.3: SerialNumber: 058F011111B1  
[  146.457414] usb-storage 1-5.3:1.0: USB Mass Storage device detected  
[  146.457759] scsi4 : usb-storage 1-5.3:1.0  
[  146.457893] usbcore: registered new interface driver usb-storage  
[  146.459336] usbcore: registered new interface driver uas  
[  147.460498] scsi 4:0:0:0: Direct-Access     SD/MMC   Card  Reader     1.00 PQ: 0 ANSI: 0  
[  147.460920] sd 4:0:0:0: Attached scsi generic sg5 type 0  
[  147.876455] sd 4:0:0:0: [sde] 61896704 512-byte logical blocks: (31.6 GB/29.5 GiB)  
[  147.878693] sd 4:0:0:0: [sde] Write Protect is off  
[  147.878698] sd 4:0:0:0: [sde] Mode Sense: 03 00 00 00  
[  147.880945] sd 4:0:0:0: [sde] No Caching mode page found  
[  147.880950] sd 4:0:0:0: [sde] Assuming drive cache: write through  
[  147.893705]  sde: sde1  
[  147.905230] sd 4:0:0:0: [sde] Attached SCSI removable disk  

The card can be used on Windows, I can read, write and copy files on the PC but not in the phone, and I cannot format it in any way.

Any suggestions about what I could try?

2

You should try to format the card from the phone while plugged into the computer instead of a USB adapter. Try the following steps:

  1. Connect your Android device to your PC and mount it as a disk drive (i.e. mass storage mode).
  2. On your PC, open Computer or My Computer and find your SD card/removable drive
  3. Right click on your SD card drive in Computer or My Computer and select "Format..."
  4. Leave all default settings and select "Start"

I took the steps from this link as I don't have a cable to plug mine in at the moment: https://www.companionlink.com/support/kb/How_to_repair/format_a_corrupted_Android_SD_card

  • Thanks, but the SD card is on the phone itdoesnt appear in the computer, probably because the phone says the card is damaged and must be formatted. But I'm thinking now that I should try to put the card in another phone to see if i can format it this way. – Sergio de Cima Dec 1 '16 at 18:29

protected by Community Oct 9 '18 at 17:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.