3

Added a 5Tb drive and trying to mirror my data drive (1.5Tb). When I add the drive, it shows 2 partitions , one is 2048gb, the other 2609gb. I wish it was 1 fully unallocated partition and am not sure why they're split but they're both unallocated. I converted my data drive to a dynamic disk so i could 'Add mirror' to one of the new partitions but it's greyed out. Why is it greyed out?

Running windows 10 pro.

10 Answers 10

2

The reason it's grayed out is most likely due to it not being part of your storage pool. To set up the storage pool, hop in to control panel and select 'storage spaces'. Set up your alternate drive into your pool, and you'll be set. Here are some resources to help you on your way:

http://www.windowscentral.com/how-use-storage-spaces-windows-10

http://www.howtogeek.com/109380/how-to-use-windows-8s-storage-spaces-to-mirror-combine-drives/ (specifically for win8, but still relevant)

4
  • Is there a way to create a storage space without losing data on my data drive?
    – asp316
    Dec 1, 2016 at 20:07
  • 1
    Unfortunately, the only way to do that at the moment is to move the data to a third drive before making it a mirror. Dec 1, 2016 at 21:30
  • 3
    The "Add Mirror" function in the diskmanager has nothing to do with the storage pool function.
    – habakuk
    Aug 4, 2020 at 21:26
  • 1
    this should not be the accepted answer. "Add Mirror" is not the same as "Storage pool". Add Mirror options became available after I have removed the second drive of equal size.
    – Alex
    Dec 8, 2021 at 9:15
5

I read the accepted answer and feared that Windows 10 was now suddenly going to force me to clear my drive and setup a "Storage Space" before mirroring it, even though this was not the case in Windows 7. Turns out, this is not the case at all.

I was having the same issue. Here are the steps I took to fix it:

  1. Installed new HDD and opened Computer Management to see my healthy data drive along with the new drive, which I initialized as GPT. When I right-clicked the data drive, "Add Mirror" was grayed out.
  2. Tried converting both the new drive and the existing data drive to Dynamic. No change.
  3. Tried formatting the new drive. No change. Decided to delete the new partition and leave the empty drive un-partitioned for the time being.
  4. With the now un-partitioned new drive and the still healthy existing data drive, both set as Dynamic, I was still getting a grayed-out "Add Mirror." I checked the properties, and sure enough, I had initialized the new drive to GPT but the existing drive was actually initialized as MBR. I tried converting the empty drive to MBR.

At this point, when I right-clicked the existing data drive, "Add Mirror" was no longer grayed out. I was able to mirror the existing drive with all data in tact to the new empty drive.

So to recap: both drives Dynamic, both drives MBR, left the empty drive un-partitioned, and "Add Mirror" worked perfectly. I am using Windows 10 Enterprise.

2
  • I have just confirmed that this still works as of 2022.
    – ssxdots
    Jan 12, 2023 at 15:00
  • Thank you! I followed what you did and it also worked for me!
    – Dev 404
    May 5, 2023 at 16:42
3

To make any drive bigger than 2tb appear as one space, it needs to be converted to a GPT disk in windows Disk Management.

It is possible to add a mirror without using windows Storage Spaces or losing data on the source disk. In windows Disk Management, ensure your destination disk is an empty, unallocated basic drive of equal or greater size than your source disk. Right click on your source disk, and 'add mirror' should be there, not greyed out.

It was greyed out for me when I first tried because I had formatted the destination drive - the key is for the destination to be unallocated. Do this by right clicking the destination drive and choosing 'delete volume'.

I'm on Windows 10 Pro 1903.

2

My mirror option was grey until I unalocated volume and had left disk free.

1

For the people running Home edition, you'll need to upgrade to Pro or Enterprise: Software RAID Windows 10

1

I know that this is an old question, but to answer one part of the question about the 5TB (for anyone who finds this page through G), MBR allows partitions of up to 2 TB (2048 GB). Converting the disk to GPT allows partitions much larger - up to approximately 9.4 ZB.

Ref: https://en.wikipedia.org/wiki/GUID_Partition_Table#History

2
  • What question are you answering?
    – Toto
    May 27, 2018 at 16:54
  • 1
    "When I add the drive, it shows 2 partitions , one is 2048gb, the other 2609gb. I wish it was 1 fully unallocated partition and am not sure why they're split but they're both unallocated." - from OP's initial post May 27, 2018 at 18:32
1

It's important that the disk you are trying to add (which should be same size or bigger than the source disk) has no volume. So you need to 'delete volume. Once Disk Management finds a sufficiently big unassigned disk, the 'Mirror' option on the source disk will no longer be greyed out.

1

In addition to what Pete said... I had two identical (brand & model) 2TB drives. One of them was fully allocated and had data on it. The other was fully unallocated but the Add Mirror function on the first drive was still greyed out. I then noticed in one person's how-to video that his existing drive had a little bit (327mb) of unallocated space.

I Shrank my first drive by 327MB and viola, the Add Mirror function was available. I chose the second drive and it started resynching. It has not finished yet but the unallocated space on the first drive went down to 199MB.

0

Initially, I could not add the drive even though I made the drive unallocated. PROBLEM: In computer management if I right click in the left column, the "next" button is grayed out when I am in the process of choosing the drive to add.
FIX: If I right-click on the white square of the drive i am adding the mirror to, then I see only the new unallocated drive, then I get the "must convert to dynamic disk" dialogue, then I can add the disk etc. easily.

0

Assuming all your other ducks are in a row, a seemingly common issue is that the source partition sometimes (incorrectly) ends up exactly 1MB larger than the unallocated space, causing Add Mirror to gray out.

This seems to be a Windows bug and happens when you change things a few times, for example it just happened to me again when I broke the mirroring of a single partition (the drive has multiple partitions, some of which are mirrored), and then deleted the mirror on the 2nd drive back to unallocated space. This should have left exactly the same amount of space so I could mirror the source again - but somehow the source partition was now 1MB too large, which caused Add Mirror to gray out.

Try shrinking the source partition just 1MB via Disk Manager (or failing that try a bit more), that has worked for me twice now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .