USB automount worked well for several month but after some updates Nautilus displays enter image description here.

With these commands it works well :

aubin@Breizh-Atao:~$ sudo fdisk -l


Disk /dev/sdf: 15.6 GB, 15610576896 bytes
119 heads, 55 sectors/track, 4658 cylinders, total 30489408 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

   Device Boot      Start         End      Blocks   Id  System
/dev/sdf1   *        8064    30489407    15240672    c  W95 FAT32 (LBA)
aubin@Breizh-Atao:~$ sudo mount -t vfat /dev/sdf1 /media/usb/

How can I recover the correct settings, available with automount?

Note: uname -a returns

Linux Breizh-Atao 4.6.0-040600-generic #201606100558 SMP Fri Jun 10 10:01:15 UTC 2016 x86_64 GNU/Linux

It seems an authorization issue. Of course, root have permission to mount but others users aren't allowed by polkit to automount. ( later lasts updates )

For Debian or derivatives, create:

 sudo vim /etc/polkit-1/localauthority/50-local.d/55-storage.pkla


[Storage Permissions]

Add your user to plugdev group: ( Usually added by default)

 sudo usermod -a -G plugdev <your username>

and reboot.

Source: https://unix.stackexchange.com/questions/66654/how-to-mount-usb-stick-on-debian-sid

  • 1
    No, your proposal has no effect, the message is still displayed. – Aubin Dec 2 '16 at 23:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.