14

It seems that "Shut down" in Windows 10 actually means "Shut down and hibernate". This has caused my NTFS partitions cannot be automatically loaded on Linux (Ubuntu 16.04) on my dual-booting laptop. There will be an error message basically saying

Unable to access “My Drive”

Error mounting /dev/sdb4 at /media/D Center: Command-line `mount -t "ntfs" -o  "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdb4" "/media/D Center"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sdb4': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option

After a "hard" shutdown by pressing Shift while clicking on "Shut down", Windows actually shuts down, and the NTFS partitions can then be automatically mounted by Linux in another bootup. This issue only occurs recently after my upgrade of the Windows OS and BIOS.

My question is the following: is there any way to make the "Shut down" on the menu as the truly/hard shutdown by default? Thanks!

  • 1
    Just use Shutdown.exe -s -t 00 to shutdown your computer. The current answer and only to this question, keep hibernated shutdown enabled, so I wouldn't recomend it. I will find the duplicate to this question after I have a better internet connection – Ramhound Dec 1 '16 at 23:08
  • Just use Shutdown.exe -s -t 00 to shutdown your computer. The current answer and only to this question, keep hibernated shutdown enabled, so I wouldn't recomend it. I will find the duplicate to this question after I have a better internet connection – Ramhound Dec 1 '16 at 23:08
  • You edited your question to emphasize that "This issue only occurs recently after my upgrade of the Windows OS," which makes sense. But did you try our suggestions to alleviate the problem? – Run5k Dec 3 '16 at 5:14
  • @Run5k, I have read your solution, but I haven't got a chance to restart my computer yet. I will definitely try in my next restart once my work is done. Thanks! – Xiaodong Qi Dec 3 '16 at 8:08
14

Have you tried to disable the Fast Startup function? Here is a good article that describes what it does, along with the potential drawbacks:

The Pros and Cons of Windows 10’s “Fast Startup” Mode

That being said, Fast Startup is on by default and disabling it will probably alleviate your problem:

  1. Press Windows Key + X
  2. Select Power Options

    Power Options

  3. Select Additional power settings on the right

    Additional power settings

  4. Select Choose what the power buttons do on the upper-left

    Choose what the power buttons do

  5. Select Change settings that are currently unavailable

    Change settings that are currently unavailable

  6. Scroll to the bottom of the window and uncheck the box associated with Turn on fast startup

    Turn on fast startup

  7. Click the button to Save changes

  8. Reboot your system

(Source)

  • Isn't it easier to just use Shutdown.exe -s -t 00? – Ramhound Dec 1 '16 at 23:07
  • @Ramhound , yes, absolutely... that is an excellent suggestion. But then again, it is also easier to hold Shift while you select Shutdown. Since the author emphasized "My question is the following: is there any way to make the Shut down on the menu as the truly/hard shutdown by default?", I assume that he wants a set-it-and-forget-it solution that will accomplish his specific goal. – Run5k Dec 1 '16 at 23:15
  • Just restarted my computer with settings as described in this post, and I found everything worked out now. Thank you for answering this question in such a detailed fashion for a simple and easy-to-operate solution! – Xiaodong Qi Dec 4 '16 at 0:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.