1

Unable to set default browser to Chrome.

Neither from system side

enter image description here

not from Chrome side.

If I select Chrome in system settings, it just doesn't set. If I select to be default from Chrome, it opens the same system window.

2

Try setting a different browser as your default first and see if it works. Then try launching chrome from administrator and set it as default in settings again if that doesn't help, try reinstalling chrome.

| improve this answer | |
  • How lazy I turned! Had this idea, but decided to post SE first! – Dims Dec 2 '16 at 14:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.