0

I'm having an issue with a Windows Server where it can ping a specific hostname but has no HTTP access to it. The server does have internet connection (google.com, superuser.com, etc), it's only two specific websites which are hosted in a different server I have with the same hosting company.

The two websites are available from every other computer, the only one that doesn't have access to it is this specific server. When I do a ping request to website.com I do get a valid response, however if I try to access it via browser (I've tried several browsers) I get a timeout error. Inspecting with Fiddler shows a HTTP 502 error code. I also noticed that nslookup website.com command resolves a different IP address (incorrect) than ping. Again this happens only from this specific computer (server)

Things I've done:

  • Added an entry to host file just in case the DNS is messing up (removed the entry after it didn't work)
  • Flushed the DNS cache
  • 502 is an error with the website, or some cache between the server and the website, not the server. – Darth Android Dec 2 '16 at 16:37
  • Add some lines from end of IIS logfile. It's inside inetpub\logs\Logfiles – SuB Dec 2 '16 at 17:09
  • @SuB there are no IIS log entries related to access from that specific computer. The website isn't actually being hit by the requests being sent from that server – alerancur Dec 2 '16 at 23:16
  • 502 means there was some proxy error. Are you connecting directly or using some proxy/gateway? – cascer1 Dec 6 '16 at 10:34
0

Check the other computers and see if they can reach the website without the cache, they may have copies of the site they're using while the site may be down.

Also check the other computers for their results on nslookup, they could be different. I'd check to see which DNS they're using. You can use nslookup website dnsip to force nslookup to find the records from a specific DNS. I had a similar issue where it turned out google's public DNS had missing records for a website and my local ISP's DNS was correct (but the computers on the network were a mix of the two configurations for some reason).

You might want to try for example: nslookup website 192.168.1.1 to use the router's DNS and nslookup website 8.8.8.8 to check on google.

  • I did clear the browser data completely and flushed the DNS cache but still nothing. nslookup returns the same result with Google's DNS and the router's DNS – alerancur Dec 2 '16 at 23:25
  • So then you've got nslookup and ping results that don't match up for some reason, but nslookup is being consistent. Can you ping the ip address of the target website from your machine as opposed to using its hostname? – TheUnknownGeek Dec 3 '16 at 7:00
0

The solution to this problem was to change the DNS record to point to the hosting server's primary IP address. The server where the website is hosted has multiple public IP addresses, but for some reason, IIS was not picking the requests sent from the problematic computer, or they were not being sent correctly by the client. So the solution we found was to edit the bindings in IIS to use the primary IP address and change the DNS A record

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.