9

After a recent update, or after I played around with installing Ionic Framework and Visual Studio 2015 Community Edition, right after a restart, I suddenly have not 2, but several monitors detected by Windows 10. enter image description here

Screen 1 is my laptop screen, and screen 2 is my monitor, connected via HDMI. When they first appeared, some of them were duplicated in groups of 2, while others were extensions.

When I disconnect my monitor, these screens don't disappear, and even worse - I can't disconnect one of these "screens", so I have to duplicate it with my laptop screen.

I have alleviated all major symptoms of the problem, except for one more: The sound from the speakers embedded in my monitor has also ceased to work.

With all of that, I really don't want to fix any more symptoms, but want to get to the core of the problem and remove all of this junk.

I tried uninstalling Intel(R) HD Graphics 4600 drivers, but they got themselves re-installed and all of this junk re-appeared again.
I tried several restarts obviously, and it didn't help.
I tried disabling the device from the device manager and it didn't have any effect. Under the "Monitors" section of the Device Manager in Windows I have 4x "Generic Non-PnP Monitor", and 2x "Generic PnP Monitor".
I tried restoring from a restore point but that failed miserably (with a memory error right at the start).

What might be causing it? And how can I fix it?

  • open device manager, goto monitors, remove all non PnP... – Adam Silenko Dec 3 '16 at 17:58
  • They re-appear immediately afterwards – AlexanderMP Dec 3 '16 at 18:25
  • select one, display property window, go to details tab, write device ID and Path – Adam Silenko Dec 3 '16 at 18:51
  • No device ID field, nor field that would yield anything useful, but here is the Device instance path: DISPLAY\Default_Monitor\4&23ACA7F2&1&UID200779 DISPLAY\Default_Monitor\4&23aca7f2&1&UID208979 DISPLAY\Default_Monitor\4&23aca7f2&1&UID217179 DISPLAY\Default_Monitor\4&23aca7f2&1&UID225379 The other 2 I recognize as a Philips (external monitor) and LG (laptop screen probably) – AlexanderMP Dec 3 '16 at 19:20
  • did you have some virtual desktop? – Adam Silenko Dec 3 '16 at 19:49
3

On the rare occasions that I have seen this happen before, it is usually caused by the display driver.

Faced with the same scenario, I would manually create a System Restore point as a potential fall-back and then check for an updated graphics driver to install. If you are already running the latest version, try dropping back to an older version and see if it alleviates the problem.

  • 1
    After your answer, I tried getting an even older version of the driver (from May or June 2016). Before that I got the latest from Intel, which was already older than the one installed by Windows updates. This solved my issue with the monitors. I still have no sound, but I guess that's a different topic. Thanks! – AlexanderMP Dec 3 '16 at 21:59
  • @AlexanderMP does Ionic enable / require hyper-v? Seems like a couple of us are seeing the same issue you had, and I resolved it the same way you did (installing older drivers). I was using hyper-v through docker, though. – dvlsg Dec 7 '16 at 18:19
  • @dvlsg, no, I don't think it did install hyper-v. It would have conflicted with my pre-existing virtualBox installation. I haven't had much time to explore this issue since then. I preferred using my second OS - Ubuntu for multimedia and work. I'll probably just trash the OS entirely because nothing that i did brought the sound back. – AlexanderMP Dec 7 '16 at 21:31
6

In case someone else is having the same problem, this is what worked for me. I am on an Asus N550JV and the problem occurs only with hyper-V enabled.

Device Manager -> Display Drivers -> right-click on Intel(R) HD Graphics 4600 -> Update Driver -> browse My Computer for driver software -> Let me pick from a list -> Choose the device driver whose version starts with 10.* I have two more options that their version starts with 20.* and neither of them fixed my problem.

You might need to download the drivers from the official site (Intel).
enter image description here

  • Having the same issue on Windows 10 after installing Hyper-V for docker. I can confirm this solution work for me after installing the 10.18.15.4256 driver for my HD Graphics 4600. – americium1997 Dec 2 '17 at 7:51
  • Asus laptop - Upgraded Windows 10 to Pro, enabled Hyper-V, gave same issue. Upgrading to driver 15.40.37.4835 solved issue. – Nattrass Mar 18 '18 at 16:06
  • It's funny that every time I have the same problem I end up here not remembering that I posted this :D – user556438 Apr 30 '18 at 19:55
  • I have just resolved this issue on my N550JV. The issue was definitely laptop using nvidia instead of Intel graphics by default after Hyper-V is enabled (I think intel driver is actually were crashing when in hyper-V mode). - Just deleting Intel driver caused windows to install 10.18.15.4256 – Pavel Luzhetskiy Aug 13 '18 at 8:12
5

Intel's most recent drivers for this graphics adaptor (version 15.40.37.4835) seem to fix the problem of phantom monitors when Hyper-V is enabled.

  • I can confirm, I just updated the driver (just through device manager; it found the correct one). This updated to driver version 20.19.15.4835 and it's all better now. – Iguananaut Feb 26 '18 at 10:27
  • I also agree. This solve the problem by upgrading to the version @Iguananaut mentionned. Thanks – vdegenne Mar 22 '18 at 22:29

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.