1

So when troubleshooting issues with my Hyper-V virtual network driver, I came up with the brilliant idea to run netcfg -d, hoping that it would fix the network issue.

However this has made matters much worse. This command removed my Intel Ethernet Connection I217-V wired network adapter! So now this PC (Windows 10) has no internet at all. It has no wireless adapter.

After a few hours troubleshooting, I am hoping to get your help to fix this.

I have tried to remove the driver, and let windows detect it again. The driver is visible in the Devices Manager, but not in the adapters list in the Network Center.

Also, I have downloaded the latest drivers from the Intel website. The installer quits after a while, saying that no Ethernet device could be found on the system.

Also I have tried running sfc /scannow and the Windows network troubleshooter, but none of these have been able to fix the issue. Sadly, there's also no system restore point available.

Help! How can I restore this troubling adapter so it becomes visible again in the Network Center?

2
  • exact same issue
    – Kiwy
    Sep 14 '17 at 13:14
  • @Kiwy I had solved it using Windows Repair from tweaking.com
    – Forza
    Oct 23 '17 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.