0

I have two separate RPis I have only ever used headlessly using my Mac (OSX). When I set up my first RPi I used an online tutorial wherein I went into System Preferences->Network and changed 'Configure IPv4' to 'Using DHCP with manual address' (as opposed to DHCP) and then inputted a static IP (i.e. 192.168.x.x). I was able to SSH into my RPi without difficulty using

ssh pi@192.168.x.x 

and set up my Raspbian GUI.

Later, I then plugged in my second RPi. I had not changed any of the settings mentioned above, figuring the IP address would be the same but when I tried to SSH into the RPi using the same 192.168.x.x as the IP, it would not accept the default password. I then manually changed the IP address to 192.168.y.y (same subnet) but still had the same problem. I changed the IPv4 setting back to DHCP, got a new IP (192.168.z.z) and tried again with the same outcome.

At this point I couldn't SSH into either of my RPis anymore. Googling told me that I was likely not inputting the correct IP address for the device. However, I used

ifconfig 

and got the en0 IP from there and then tried to SSH using that. Again, no dice. In all instances the problem is that I am asked for the password and the default password is not accepted. I KNOW this is the correct password - I never changed it.

I was able to solve this problem with my first RPi by re-downloading Raspbian and adding a line of code to one of the default files specifying a static IP (e.g. 192.168.a.a) before writing it to the SD card and then setting the IPv4 on my Mac to 192.168.a.b. However I'm so annoyed that I don't know what's going on here. I can't access the second RPi at all. Can anyone help me understand why I cannot talk to it? All of the IPs I've used (static and non) have been on the same subnet. The problem seems to be that SSHing is possible (I am asked for the password) but I just cannot access the device. I'm using the same cable to connect to both RPis (the one I set up with the static IP that now works and the second one I have not set and does not work) so I know both are connected to the laptop via the en0 connection. I don't have direct access to the router or peripherals at the moment which is why I'm doing things this way.

0

as you mentioned a Mac, maybe you used an SSH-key for login (usually root-login is only allowed with ssh-key, this can be extended to any user), and updated the Mac - I know with one of the last updates the start of ssh-agent/system-keyring was broken (check the reason in /var/log/auth.log after pulling out the SD card)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.