0

I have just set up ubuntu server, and I cant figure out this stupid xfinity router/modem. So what I've managed to do is set a static ipv6 on ubuntu server

iface enp4s0 inet6 static
address 2601:407:8402:38bc:0000:0000:0000:0010
netmask 64
gateway 2601:407:8402:38bc:0000:0000:0000:0001

Then on godaddy I set AAAA (IPv6 Host) to

2601:407:8402:38bc::10

I have opened up ports 80 & 3306, and on my browser I can navigate to my website, but when I try from my phone (with wifi off) I am unable to navigate to my domain and my ip(v6)

[2601:407:8402:38bc::10]

Another route I have already tried is disabling ipv6 altogether but for some reason even with ports open and canyouseeme able to see my normal ip / ports, I can not able to access my server, I have never had this type of problem with any other router/modem so the problem probably lays with that.

I figure there has to be a way to get this all set up with ipv6 although the way ipv6 is, it just confuses me. Is there anyway I can get my ipv6 address and use it for my domain on godaddy.

This is my ifconfig

enp4s0    Link encap:Ethernet  HWaddr 38:60:77:fa:98:6b
      inet addr:10.0.0.66  Bcast:10.0.0.255  Mask:255.255.255.0
      inet6 addr: fe80::3a60:77ff:fefa:986b/64 Scope:Link
      inet6 addr: 2601:407:8402:38bc::10/64 Scope:Global
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:43574 errors:0 dropped:0 overruns:0 frame:0
      TX packets:34340 errors:0 dropped:0 overruns:0 carrier:1
      collisions:0 txqueuelen:1000
      RX bytes:27639502 (27.6 MB)  TX bytes:16077266 (16.0 MB)

Or maybe I already did everything right and the DNS just needs to update...

Domain that should load http://dirtrif.com

migrated from serverfault.com Dec 5 '16 at 3:20

This question came from our site for system and network administrators.

  • from the server, can you get to ipv6.icanhazip.com – Jacob Evans Dec 5 '16 at 2:47
  • its a ubuntu server i have physical access to but I dont know how to browse the web on it I use putty theres no gui – your mom Dec 5 '16 at 3:09
  • just found and installed ELinks (terminal browser that only loads text) let me see if I can figure this out – your mom Dec 5 '16 at 3:16
  • Why have you set a manual IPv6 address? This is not the normal way to set up IPv6 on Comcast. – Michael Hampton Dec 5 '16 at 3:20
  • 1
    reconfigure you ipv6 for autoconfigure, type curl ipv6.icanhazip.com – Jacob Evans Dec 5 '16 at 3:46
1

use autoconfigure and then set a secondary address to use with your apache config

fist 4 sections are your delegated prefix.

last 4 sections are yours to set (64bit network/64 bit host)

add this after your iface config

up /sbin/ipconfig enp4s0 inet6 add  2601:407:8402:38bc::10/64

this doesn't mean comcast isn't going to filter the ports, but it should work locally.

remember you have public or registered ip addresses, but that doesn't mean you don't have a firewall. you may need to open ports there as well.

these addresses are not static, but typical lifetime for ipv6 prefix delegation is lifetime.

  • updated for ubuntu – Jacob Evans Dec 5 '16 at 4:20
  • I have allowed the ports through the router and through the firewall and even disabled the firewall. My complete network/interfaces looks like pastebin.com/WxvJdmmp and I'm opening my ports like imgur.com/a/hkdfN should i change those to the ipv6 one and only put 10 in the last box? – your mom Dec 5 '16 at 4:24
  • you aren't port forwarding, you want to open the firewall for that IP, port forwarding maps the router v6 to the internal server you specified – Jacob Evans Dec 5 '16 at 4:28
  • and the up sbin command is one line – Jacob Evans Dec 5 '16 at 4:28
  • 1
    I'm not convinced port 80 is an option on comcast residential service – Jacob Evans Dec 5 '16 at 4:39
0

You shouldn't need to set a manual ipv6 address - you just need to set up your router for SLAAC or stateless connections, and set your ubuntu box for it. While I'm not on comcast, my ISP uses the same method and it just works automatically.

Since ipv6 seems to work on other systems, you simply need to replace your static address stanza with iface enp4s0 inet6 auto bring the interface up and down, and check and test that IP. ping -6 google.com should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.