I've got a Dell XPS 13 (9360) with Windows 10 Home.

Steps to reproduce:

  • Open power options (Win-X, O)
  • Click change plan settings next to the current plan ("Dell" in my case)
  • Set both "on battery" and "plugged in" change "Put the computer to sleep" to something high or "Never" (I have 15 mins for battery, 1 hour for plugged in, tried "Never" for both too)
  • Click save changes
  • Open screen saver settings (Win-S, Change screen saver)
  • Ensure screen saver is off (None)
  • Ensure "On resume, display logon screen" is off
  • Click OK
  • Lock computer with Win-L
  • Wait...

Expected behaviour:

  • Screen switches off after a short delay (~30 secs).
  • Computer stays on, crunching whatever data you've left it to do.

Actual behaviour:

  • Screen switches off after a short delay (~30 secs).
  • Computer goes to sleep after a further ~15 seconds.

I would've thought this was a simple problem, but I've spent over two hours Googling etc for a solution. The closest I could find to my problem was this, which is similar but not the same, and the solution doesn't work for me:

  • What happens if you choose "Never" for "Put the computer to sleep". Locking the computer is not supposed to put it to sleep if you ask me. This is my preferred choice. For sleep you can close the lid (if it is a laptop) or use Alt-F4 and choose the option to actively put it to sleep. – Michael S. Dec 5 '16 at 15:42
  • @MSC "Never" makes no difference. It even goes to sleep when locking while it's plugged in. – Dave E Dec 5 '16 at 15:46
  • @DaveE Do you have any "energy optimization" software (I call it bloatware) installed? I have seen those preinstalled on some devices, check for any programs by Dell, Intel or other hardware manufacturers. – Hexaholic Dec 5 '16 at 15:52
  • It could be a Dell specific feature that needs to be changed which may overrides Windows Power Options – Sanny Dec 5 '16 at 15:52
  • @Hexaholic - It's really not bad, bloatware-wise. I can't find any Dell-specific power apps etc, only a Dell power plan. The standard "Balanced" plan has the same behaviour. – Dave E Dec 6 '16 at 7:38

After running PowerCfg /q and reviewing this page, I believe I have determined the solution to this problem.

There appear to be many power settings that just don't show up in my advanced power options window. One is Sleep → System unattended sleep timeout. To make it visible, I opened regedit.exe and found this key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0

Set its Attributes DWORD value to 2. This will make it show up in your advanced settings. Go there and configure it to be zero minutes if you don't want it to sleep when you lock your screen.

  • 4
    If you vote me down, please provide a comment so I can improve my answer. – Rob M Mar 9 '17 at 14:25
  • Awesome ! Had this problem with my SP3, it was driving me nuts...! After making the register change, it shows "Standby if the computer is not used" parameter in the Power settings (under "Standby"). – Michaël Polla Aug 29 '17 at 9:18
  • 1
    This definitely worked. I can't believe they hid this option behind a registry flag, and that it's different than the normal sleep setting. So dumb! Thanks for the help! – qJake Oct 2 '17 at 17:35
  • 3
    Lenovo thinkpad here, this is the only thing that fixed my issue. It was set to 2m by default and I couldn't change it without this hack. Stupid windows. – Anyone Jul 3 at 10:49
  • 2
    After changing that registry value, I had to right click on the desktop and go to Display Settings, then click 'Power & sleep' on the left, then click 'Additional power settings' on the right, then click 'Change plan settings', then click 'Change advanced power settings', then expand the 'Sleep' setting, then expand the new 'System unattended sleep timeout' setting and this is where you can up the minute value so it doesn't sleep after 2 minutes or whatever. – tclark333 Sep 26 at 11:38

Thanks, very helpful.

I found this official link about this on Microsoft Docs which I thought might be helpful:

Sleep unattended idle timeout, Windows Vista with Service Pack 1 (SP1), Windows Server 2008 R2, and later versions of Windows.

Specifies the duration of inactivity before the system automatically enters sleep after waking from sleep in an unattended state.

For example, if the system wakes from sleep because of a timed event or a wake on LAN (WoL) event, the sleep unattended idle timeout value will be used instead of the sleep idle timeout value.

Aliases and setting visibility Windows Provisioning: UnattendTimeout

PowerCfg: UnattendTimeout

GUID: 7bc4a2f9-d8fc-4469-b07b-33eb785aaca0

Hidden setting: Yes <-- Unhidden with: Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0\Attributes = 2

Values The value denotes the number of seconds.

Minimum value: 0 (Never idle to sleep) Maximum value: Maximum integer

We had the same issue with a bunch of XPS 9370s, the laptop went into standby after the screen was locked. We have one laptop where the issue did not occure and exportet it's power scheme. By importing it to the other XPSes were able to make them have as expected - but by now we have no clue why.

You can findn the exported power scheme here: https://www.dropbox.com/s/mvajdkh14358471/dell.pwr?dl=0

Import it with an elevated prompt: powercfg /import 'fullpathtofile'

I also found this about letting Console Lock been seen - and changed. This allowed my power options to change it to 0 minutes, and then allowed screensaver to actually start.

https://www.eightforums.com/tutorials/8267-power-options-add-console-lock-display-off-timeout.html

HTH

  • 4
    External links can break or be unavailable, in which case your answer would not be useful. Please include the essential information within your answer and use the link for attribution and further reading. Thanks. – fixer1234 Jan 25 at 18:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.