10

When I press the power button on my Epson WorkForce WF-3520 printer, it starts up normally, but shuts down within 30 seconds. Ten seconds later, it starts itself and the stop/start cycle is repeated again and again. This has only started happening today (6th December 2016).

  • I see that two or three other people are having the same problem and each is reporting the problem as starting today – Andrew McCulloch Dec 6 '16 at 16:55
  • Yea, you're the third. They're also all first time askers with 1 point and interesting names. Makes me wonder if someone is trying to convince Epson an issue is bigger than it is. Then again, as a long time IT professional, I may just be a bit too suspicious than is healthy. – music2myear Dec 6 '16 at 16:59
  • 1
    Did you recently update the firmware on the device, or can you check which firmware the device is currently running? – music2myear Dec 6 '16 at 17:36
  • Yes, the firmware was updated on Sunday when prompted by Epson – Andrew McCulloch Dec 6 '16 at 18:10
  • 1
    To anyone with this problem. Please don't make a new question, to indicate you have the problem also, or the solution in this question worked. Come to our chatroom to discuss your problem instead. – Ramhound Dec 7 '16 at 3:52
8

Got online help from Epson:

I had exactly the same problem, and this worked. They knew right away and told me to do this:

Shannon: You will need to disable Google Cloud Print. Please turn the router off and then turn your printer on. . Select Setup > Select Google Cloud Print Services > 'Select Suspend/Resume'. Select 'Yes'.

Shannon: Please then turn the router on and let us know if the same issue occurs or not.

(the setup is on the printer screen by the way)

Epson has added a FAQ regarding this solution: My Printer Keeps Restarting. What Should I Do?

  • That's awesome. Once we can get a few more confirmations that this worked, we can roll these questions up as duplicates of this one. Thanks Bob. – music2myear Dec 6 '16 at 18:04
  • Does this printer connect wirelessly to your network? Can you just turn the wireless off on the printer instead of turning off your wireless router? – music2myear Dec 6 '16 at 18:05
  • I wonder why the problem suddenly occurred? Has Google altered something I wonder? Epson's reply was instantaneous- so credit to them. Let me know if you get to the bottom of why this happened? Thanks – Bob Dec 6 '16 at 18:16
  • It's possible. Or someone figured out how to hack Cloud Print and find its endpoints, and now they're DDoSing them. Though why its only this model seems to mean that's not the case. I assume we'll find out in a few days or weeks. – music2myear Dec 6 '16 at 18:18
  • 1
    @Yardboy - Contact Epson for support. – Ramhound Dec 7 '16 at 3:35
2

I found two ways to fix this.

  1. Suspending Google Cloud Print Services
  2. Re-install the printer from scratch

Suspending Google Cloud Print Services

Open your browser and substitute your printer’s IP address in the URL as shown below, which will guide you to the page to disable Google cloud print services.

http://###.###.#.#/PRESENTATION/GCP

With your printer on repeatedly hit the refresh in the browser until the above page loads - you will have to be quick because the printer will shut itself off. If your printer was already online and ready, disable the google service before you turn it off!

When the page loads, look for the Google Print services info and press the Suspend button.

The printer will now boot into a stable state.

Note: If you have a USB cable you can connect your printer to your PC and follow the above pretty much.

Re-Install my printer from scratch (if you use WiFi)

If you get caught in the loop of not being able to connect to your printer via it's IP address in the URL then you may need to take it back to the beginning and re-install the printer from scratch. I completed the following: 1. Switch off your printer 2. Switch off your router 3. Power on your printer and set it back to default settings 4. Power on your router 5. Connect your printer via WiFi to your router (select your WiFi network and manually type in your router password) 6. Install the latest driver for your printer on your PC 7. Check if the printer is online. Try to print. 8. If you need to you could input your printer IP address into a URL and check if you need to suspend Google Cloud Print Services. I didn't have to do this. Note your printer may have a new IP address so check if you can't access via the URL. To locate the new IP address (printer properties > Port tab and you'll find it in the list).

Good luck as this was a real pain today. Or you could wait for Epson to come up with their own fix. Please keep an eye out for Epson's answer to this as you may want to use Google Cloud Print at some point.

2

Not all Epson printers have Google Cloud Print Services as an option within the printer's panel user interface.

To prevent the boot loop:

  1. go to https://www.google.com/cloudprint#printers and remove your printer
  2. turn your Wi-Fi router off
  3. turn your printer on
  4. reset the network settings on your printer
  5. turn your router on
  6. set up network on your printer

Until Google and Epson resolve this issue, do not register your printer with Google Cloud Print Services.

Many reports of this issue have been made in this Chromebook Central Help Forum thread.

  • To confirm what others were saying, this started up this morning. Because my printer was rebooting so quickly, I had to use earthsound's version. – rsjaffe Dec 7 '16 at 16:50

protected by Community Dec 6 '16 at 19:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.