26

I get a warning "There are some data after the end of the payload data" when extracting an archive. What does this mean? Is the file corrupted?

6
  • 1
    Basically, I did a search on this error and 7zip and it was a known issue a few versions back, but it may be related to using the RAR encryption on certain types of data. I haven't done any more research at this point and don't have the time today to do so, but it may be worth googling to see what you find. Dec 8, 2016 at 1:00
  • 1
    What is the filetype(s) of the date you're compressing, and what is the approximate uncompressed data size? Dec 8, 2016 at 16:17
  • @music2myear: ISO, ~ 1,5 GB. Can't share the file sadly.
    – user598527
    Dec 8, 2016 at 16:37
  • 1
    Yea, I don't need the contents, just the file type: ISO. Thanks. Dec 8, 2016 at 20:03
  • 1
    With 7Zip 18.06 x64 2018-12-30, and the ISO file hosted by this torrent "Windows_XP_Professional_SP3_x86_-_Black_Edition_2015.9.12", the error is still present.
    – Brethlosze
    Jan 1, 2019 at 20:25

4 Answers 4

11

It appears this is a reoccurring issue w/ 7zip. The most recent note of this that I could find is from build 16.02.

The most recent examples of this are with archives created by other archives (WinRAR, mostly), and I'm sure he'll be interested to hear of your issue with a file that was created in 7zip itself.

I recommend you bring this to Igor's attention over at SourceForge where the 7zip support forums are at: https://sourceforge.net/p/sevenzip/bugs/

1
  • With 7Zip 18.06 x64 2018-12-30, and the ISO file hosted by this torrent "Windows_XP_Professional_SP3_x86_-_Black_Edition_2015.9.12", the error is still present.
    – Brethlosze
    Jan 1, 2019 at 20:25
2

I was trying to extract a .gz file with 7zip, it stopped at 99% and the dreaded message appeared. I had to switch to PeaZip and it extracted fine but with a warning message. The extracted file worked fine. So I would suggest you to try using another program.

0

Rename the extension from .zip to .rar it will work fine. It may be not done due to compressed in another program and provide the extension as zip.

2
  • 2
    This doesn't make much sense IMO. 7-Zip ignores extensions, it looks at file structure only. ZIP and RAR are two completely different formats and changing extension won't fix the file or faulty algo.
    – gronostaj
    Jul 9, 2020 at 6:30
  • @gronostaj This was a known and recommended fix before the bug was resolved (prior to 7zip v17) Why it worked is a question you'd need to pose to the devs.
    – arkon
    Nov 27, 2021 at 16:10
0

I had a quick squiz using a zip file distributed by Macrium Reflect makers. The file is their "Rescue Media", name = "pe10_1709x64.zip", in my view genuine, excellent and trustworthy zip-file.

I opened the zip-file in 7Zip, then clicked the "Info" tool (toolbar top-right). The message I got was "Warnings: there are some data after the end of the payload data - Physical Size: 474 450 715 - Tail Size 191" see pic.

I also renamed the file to ".RAR" and again opened it with 7Zip, and got exactly the same result. I can't add any more info, BUT the extract from the trusty zip-file by Macrium is 100% effective and there is no negative outcome due to the extra payload.

enter image description here

2
  • 1
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Feb 23 at 4:52
  • If you look at the associated image you will see the message that I put in quotes. For your enlightenment, something written in quotes usually indicates a verbatum quotation. You can find more information on the use of quotation marks and grammar here: grammarly.com/blog/quotation-marks
    – THROB
    Feb 25 at 2:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.