2

What we have:

  • Windows 10 Pro amd64 1607 all updates installed
  • for one user registry key HKCU\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\shell changed to C:\Program Files\Internet Explorer\iexplore.exe -k superuser.com
  • configured autologon for this user with Sysinternals Autologon
  • there in no hardware keyboard or mouse - only touchscreen!
  • Web page works only in Internet Explorer.
  • Assigned Access not appropriate for other reasons.

The problem:

  • user can not enter data into the input field - the keypad is not displayed when input field focused.

Any solution how to enable onscreen keyboard popup, ONLY when input field focused?

2

Had the same issue with a custom shell On Win 10. Adding the following two reg entries fixed it for me:

HKCU\Software\Microsoft\TabletTip\1.7\EnableDesktopModeAutoInvoke = 1

HKCU\Software\Microsoft\windows\CurrentVersion\ImmersiveShell\TabletMode = 1

1

The problem was in hardware and it's driver.

For Windows Ink works it requires that in system present HID device with Usage 0x000D and Page Usage 0x0004 (see Microsoft docs for supported HID clients list).

But my touchscreen driver was implements only Mouse class driver and mapper driver

0

Execute TabTip.exe to start the onscreen keyboard.

Otherwise you may need to write a proper kiosk application that can invoke on-screen keybaord when needed.


An alternative may be to use Edge browser and Assigned Access(perma link).

Assigned Access will display the app above the lock screen. This has the advantage of allowing the onscreen keyboard to function intuitively, while also locking all functionality of the device outside of the application (edge browser).

There are some other settings you might want to have locked down, the linked article has several examples.

3
  • Web page works only in Internet Explorer. Assigned Access not appropriate for other reasons. It will work tabtip.exe without explorer.exe process? Now try it. – Slipeer Dec 7 '16 at 12:02
  • Starting TabTip.exe has no effect. The new process will appear, but no on-screen keyboard. – Slipeer Dec 7 '16 at 12:37
  • I am running kiosk mode with group policy setting for a kiosk account "Custom User Interface" that runs a specified kiosk application. I do not see the keyboard popping up when I select an input field in the application. – Amjad May 1 '18 at 23:17
0

I had a same issue. Adding the following two reg entries fixed it for me:

HKLM\Software\Microsoft\TabletTip\1.7\EnableDesktopModeAutoInvoke = 1

HKLM\Software\Microsoft\windows\CurrentVersion\ImmersiveShell\TabletMode = 1

2
  • 1
    Why have you copied previous answer? – Toto Feb 16 '18 at 12:34
  • 1
    Itś not the same. HKLM instead HKCU... – Fernando Nitatori Feb 23 '18 at 14:39
0

Same problem & nothing here worked for me. I figured out a workaround though.

In my case, I changed the shell to load Chrome. I googled the hell out of this and there doesn't appear to be a proper fix for it. So I went to the Chrome Web Store and searched "on screen keyboard". Installed an extension called "Virtual Keyboard".

Problem solved but that's only if you're using the Chrome browser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.