2

I know there are many questions on here regarding auto brightness/dimming, and I've been through many of them. I have a laptop (Dell Inspiron 15 7000 series) with Intel graphics. I have disabled/done the following:

  • Edited Windows Power Plan settings and disabled Adaptive Brightness for both power and plugged in modes
  • Edited Windows Display settings and toggled off 'Change brightness automatically when light changes'
  • Opened Intel Graphics Properties and gone to Power > On Battery > and disabled Display Power Saving Technology (and even the Extended Battery Life for Gaming option)

Still, my laptop (while plugged in, nonetheless) is changing the contrast on my screen when switching between dark and light backgrounds. For instance, if I have Sublime Text open with a dark theme and I switch to a localhost website, all of my Chrome tabs are faded/washed out and it takes a few seconds for them to come back to normal.

I have referenced this question here on SU, but nothing has changed since I have implemented all of those fixes. It seems like a "feature" I still can't find the setting for, because it is consistent and not at all buggy -- just ugly!

I feel like I'm chasing my tail trying to find more settings that would control this. Thanks in advance.

0

Laptop screen changes contrast drastically when switching from a dark to light application

This worked for me.

Feels like very few people realize this. Feels like they have sneaked this "feature" in to extend battery life guessing people won't notice. And they are right. Most people don't. My computer does the same. It lowers the contrast of the image, not just brightness.

  • 1
    Hey @avatar1337! Welcome to superuser. Just a heads up that this would be better as a comment as it doesn't actually the question posted. – armadadrive Apr 24 '18 at 11:16
  • Aha okay. I'll add the solution. =) – avatar1337 Apr 24 '18 at 11:21
  • 1
    What answer help you out? You can quote it to be a more appropriate answer – CaldeiraG Apr 24 '18 at 12:40
0

I have a Acer Aspire E 15 laptop and I had this issue fixed by following what you said here, although I recently updated my Windows 10 machine and then the dynamic contrast issue reappeared. For anyone who has the same issue, this is what I did to make this work, here:

  1. Click on Start and type 'services'
  2. Right-click and choose 'Run as administrator'
  3. Click on 'Intel(R) HD Graphics Control Panel Service' from the list.
  4. In the General tab click on 'Startup type', select 'Disabled'
  5. Click OK, and restart the computer.

I'd have liked to add this as a comment, but I do not have the reputation to do this, so I made it look pretty and defined it as an answer. I hope this helps anyone who finds this. Thanks.

0

My issue has disappeared after two things, and unfortunately I cannot single out which item fixed it so I'll list both steps:

  1. I updated the Dell Inspiron BIOS from A7 to A12
  2. I went into Intel HD Graphics > Power > On Battery and saw that something had enabled Display Power Saving Technology again.

Now, on battery, I no longer suffer from the adaptive contrast/brightness issue!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.