4

I plugged in my iPhone 5 with iOS 10 and saw iPhone in the file explorer. I clicked on the iPhone 'drive' but it was blank. There was a button for ShotWell and I clicked on that. Another 'folder' for iPhone was there too, but when I clicked on it, it said 'Importing, please wait...' and didn't do anything.

iphone drive in ubuntu file manager

Ubuntu 16.04, iPhone 5, iOS 10.1.1

6
  • Use the steps described here under The proper solution , before installing the required package check for the newest package version One by one – GAD3R Dec 8 '16 at 15:19
  • @GAD3R This part didn't work: $ sudo ifuse /media/chloe/iPhone --root GnuTLS error: Error in the pull function. Failed to connect to lockdownd service on the device. Try again. If it still fails try rebooting your device. It didn't work after I rebooted the phone either. – Chloe Dec 8 '16 at 19:38
  • follow this answer on AskUbuntu – GAD3R Dec 8 '16 at 20:09
  • 1
    OK I didn't install or build anything because I already had the latest version from apt, but after I edited fuse.conf according to that answer, and used the file explorer, then it worked. It still doesn't work in the command line though. – Chloe Dec 8 '16 at 21:48
  • Maybe the problem come from the libimobiledevice try to compile it from git repo , see here – GAD3R Dec 8 '16 at 22:26
0

I did the same as Chloe, only edited the fuse.conf, since I already have libimobiledevice in the latest version.

But it only worked for me using Nautilus on a XFCE desktop. The default file manager (Thunar) only showed an empty dir.

0
0

I was not able to download the files from my iPhone. I was able to get the pictures from my Free Google Drive account. Drive is one of the options one can download iPhone pictures into. Go to your Google account on the Lubuntu computer, and download them from there.

1
  • Fooled around and got it to work, after iPhone asked to Trust the computer. – easeltine Aug 31 '17 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.