2

Is there a way to prevent Microsoft Word 2010 from making any auto-corrections.

Here's one example, that causes issues when creating technical documentation for server build scripts. Copy and Pasting the auto-corrected hyphen causes the command to not run correctly.

If you type ./CA -sign, the "-" (hyphen) changes to a "-" (dash) UNICODE character. Pasting into a Putty.exe (Linux emulator session) will cause an error. It's easy to tell if the hyphen changes. It gets wider if using the default font in Word.

2 Answers 2

3

Copy/Pasting an auto-corrected hyphen causes script errors

You can disable this particular auto-correction using the instructions below.

Note:

  • As your issue is command line errors when using copy/paste into scripts you might want to consider also disabling the auto-correction of normal double quotes into smart quotes as well, as these will also cause problems.

  • That can be disabled in the same "AutoCorrect" dialog.


Turn off auto replace of hyphens with dashes in Word 2010

Turn off hyphens with dash feature

Users can turn off the auto replacement of hyphens with dashes using the option available as part of AutoCorrect settings. Click the File menu –> Options link and navigate to Proofing Option screen then click the AutoCorrect Options button in the Proofing screen.

image

In the AutoCorrect window, click the AuoFormat As You Type tab and navigate to Replace as you type section.

image

Now unmark the check box with label as Hyphens (–) with dash (—) and click OK button to confirm and save the changes.

Source Turn off auto replace of hyphens with dashes in Word 2010

0

An old entry, but this is how you'd fix on web based MS Office:

Editor -> AutoCorrect Options.. -> unselect "Replace hyphens with dash"

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.