2

This link describes a setting in about:config that limits the number of processes to 1 by default. http://www.ghacks.net/2016/02/15/change-how-many-processes-multi-process-firefox-uses/ Essentially, it talks of the dom.ipc.processCount variable. I have set this to two.

This website http://www.ghacks.net/2016/07/22/multi-process-firefox/ also says that browser.tabs.remote.autostart should be set to true.

However, I tried both, but still found that I have only one process, even though the addon compatibility reporter says multiprocess is enabled. Also, in about:config,extensions.e10sBlockedByAddons is false, and extensions.e10sBlocksEnabling is (default) true.

I saw this question: Firefox 48 e10s enabled, but still one process. The accepted answer says a single additional process is used. But I still see only one process for firefox, rather than 1 "additional process", ie., a total of two.

Is there a way to get 2 processes, or is it that only 1 process is currently supported, as of old? I'm using Ubuntu 16.04, if that makes a difference. I'm checking the processes both using the top command line utility and Gnome system monitor.

1 Answer 1

0

Enable Firefox Multi-Process manually

You can check if multi-process is already enabled on your Firefox by typing about:support in the address bar.

enter image description here It would be better if, you create a new Firefox profile to do all the changes, as, reverting back would not be as easy as, deleting the profile. In order to turn on Electrolysis on your Firefox 54 manually, you need to follow the steps mentioned below:

**Go to about:config using Firefox’s address bar.
Click I accept the risk! when the warning message is displayed (if it does).
Now, search for the term browser.tabs.remote.autostart in the search. Please pay attention while typing the Preference name or you’ll end up doing something else.**

enter image description here Double-click the option to set it to True and enable e10S. enter image description hereTo disable e10S set the value to False again.

Force-enable Multiprocess in Firefox

You can verify if the process has been successful or not by revisiting the about:support page. There might be chances that multiprocess didn’t turn on because of incompatible add-ons. The about:support page would list the cause why e10s is disabled. If that’s the case, you can force Firefox to allow electrolysis.

Go to about:config in Firefox.
Right-click > New > Boolean.

enter image description here Type the following in the name field: browser.tabs.remote.force-enable Click Ok. enter image description here Set the value to True. Now, you have to prevent incompatible add-ons from stopping electrolysis. Search for: extensions.e10sMultiBlockedByAddons Set the preference to False by double-clicking on the entry.

The about:support will display Multiprocess Windows status as “Enabled by user’ when you force it.

enter image description here Please note that there are risks associated with force-enabling multiprocess and Mozilla warns about the same in their wiki. Also, the multiprocess didn’t turn off in my case when I set the value to False. Increase the number of content processes for Electrolysis

Firefox supports up to 7 content processes, but only four are enabled by default in Firefox 54. You can change the number by searching for dom.ipc.processCount on the about:config page.

enter image description here The process count was initially set to one. Double-click the dom.ipc.processCount preference to edit its value. Set the process count to four or above. Later versions of Firefox will include an option to the same.

2
  • fossbytes.com/…
    – techvish81
    Aug 28, 2017 at 4:59
  • Thanks for the detailed answer! I had not tried browser.tabs.remote.force. However, as of Firefox 55, multiprocess started working automatically for me. Aug 29, 2017 at 21:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .