I am using a Lenovo Y580 running Ubuntu 14.04/Windows 10, which has a GeForce GTX 660M Graphics card. I'm trying to train neural networks using Caffe and it would be really helpful if I could use my NVIDIA GPU. This requires me to install appropriate NVIDIA GPU drivers and the CUDA toolkit. Here's the problem :

I am using the NVIDIA-304.132 driver. The latest version of CUDA that I can use with this driver is CUDA 5, which isn't compatible with Ubuntu 14.04. I want to upgrade to NVIDIA-340(or above), so that I can use CUDA 6.5(or above) which is the earliest version of CUDA compatible with Ubuntu 14.04.

None of the drivers released after NVIDIA-304.132 seem to work with my laptop even though NVIDIA's site claims that all drivers up to NVIDIA-375 are compatible with GeForce GTX 660M. In fact, NVIDIA-375 is specified as the recommended driver for GTX 660M both on NVIDIA's site and when I run ubuntu-drivers devices in the terminal. I have already tried NVIDIA-340, 355, 358, 361, 367 and 375. I either get a black screen or am stuck on the purple start up screen every time I try the other drivers and am forced to login using CTRL+ALT+F1 and go back to NVIDIA-304. I have already tried setting nomodeset in etc/default/grub as suggested in some threads without any change.

Is it possible for me to use NVIDIA-340(or above) as recommended by the NVIDIA site ?

This link lists the appropriate drivers required for specific versions of the CUDA Toolkit.

  • "Is it possible for me to use NVIDIA-340(or above) as recommended by the NVIDIA site ?" - I have a system with a GTX 660 card, and a Ubuntu VM, I had no problem installing the current Linux drivers on it.
    – Ramhound
    Dec 9, 2016 at 3:07
  • Can you tell me exactly which version of the driver you're using ? Also, How did you install it ? Did you download the .run file from the NVIDIA site or just run apt-get from the terminal ? Dec 9, 2016 at 3:14
  • @Ramhound "I have a system with a GTX 660 card, and a Ubuntu VM" 660 != 660M, and a VM wouldn't use a physical graphics card without VT-D
    – Journeyman Geek
    Dec 9, 2016 at 7:08
  • @JourneymanGeek - It's a Hyper-V VM that I booted to.
    – Ramhound
    Dec 9, 2016 at 15:23

1 Answer 1


I finally figured it out. I just had to run sudo apt-get update and sudo apt-get upgrade. That's all it took. Now I'm runnin the NVIDIA-367 drivers and CUDA 8. I realise now that the solution was exceedingly simple, but I am new to Ubuntu and it took me some time to figure it out. If there's someone else facing this problem, hope this post helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.