1

I am trying do dual-boot my Dell Precision 5510 (1TB PCIe SSD), that came with windows 10, adding Debian stretch.

First, I have disabled fast startup of windows and then and disabled secure boot. Then, when installing Debian from a bootable USB stick, in some moment, it prompt the windows installing grub boot loader. It shows the message looking for other operation systems for around half an hour and finally prompt the window error unable to install grub in dummy, executing grub-install dummy failed, fatal error. Hope someone can give a hand.

  • Welcome to SU , are you using a gpt table? – GAD3R Dec 9 '16 at 18:21
  • Sorry for the answer, explicitly I did not manage anything of a gpt table. But I think that the debian installer manage that when UEFI mode is recognized. If my answer is wrong, please guide me. – Erick Chacon Dec 9 '16 at 18:29
  • Boot from a Linux Live USB/CD to repair the existing installation , Create a new partition flagged bios_grub Size = 1 M , Then create the chroot environment to reinstall grub , if you don't have a linux live USB reinstall Debian , do not forget to add the bios_grub partition – GAD3R Dec 9 '16 at 18:38
  • Then, should I finish this installation (I have cancelled that) and then do what you suggest? – Erick Chacon Dec 9 '16 at 18:57
  • Reinstall the system , Create the swap , root , bios_ grub partition .... the grub bootloader will be installed correctly on your dd – GAD3R Dec 9 '16 at 19:34
1

There seem to be multiple possible causes for this failure. In my case, Debian installer failed to configure /etc/default/grub correctly. The solution I will describe worked for my particular setup on a Thinkpad 13 Gen 2

Setup

  1. Boot mode is "UEFI Only" (check the corresponding setting in the BIOS Setup).
  2. Factory installed Windows 10 booting, obviously, in UEFI mode (check the "BIOS mode" row in System Information, it should say UEFI).
  3. The disk had 3 partitions:

    1. EFI System Partition
    2. Windows NTFS Partition
    3. Recovery Partition
  4. I wanted to keep Windows for a dual boot, so I shrank the Windows partition to get room for Debian (using the Disk Management tool under Windows).

  5. Ran Debian installation from a USB stick. The installer ran in the UEFI mode (there was a text line on the initial splash screen saying "Debian GNU/Linux UEFI Installer menu).
  6. Partitioned the free space on the disk manually:
    1. Created a 256MB partition for /boot
    2. Created an encrypted volume in the rest of the free space (the encrypted volume is what Debian installer seems to have a problem with during Grub installation later on).
    3. Created 3 LVM logical volumes for root, swap, and home.
  7. The installation ran smoothly until the "Install the Grub Boot Loader on a Hard Disk" step, at which the installer failed with the message: "Unable to install GRUB in dummy. Executing 'grub-install dummy' failed. This is a fatal error."
  8. I skipped the Grub installation step and continued the installation with the next step. The installation finished successfully, but on the reboot no Grub screen was displayed and Windows booted.

Solution

  1. Boot from the installation media from which you installed Debian.
  2. In the initial menu, go to Advanced options -> Rescue mode and go through the configuration process for the rescue mode until you get a shell prompt.
  3. In the shell prompt run:
    apt-get install --reinstall grub-efi-amd64
    This should fail with the message
    grub-install: error: attempt to install to encrypted disk without cryptodisk enabled. Set 'GRUB_ENABLE_CRYPTODISK=y' in file '/etc/default/grub'.
  4. Open /etc/default/grub in an editor (e.g., nano) and add GRUB_ENABLE_CRYPTODISK=y as the last line. Save the file.
  5. Run
    apt-get install --reinstall grub-efi-amd64
    update-grub
  6. Run exit and reboot.

You should now get a Grub menu with the options to boot Debian and Windows.

UPDATE

I found out that Debian installer ignored the separate /boot partition I created and tried to install Grub to the boot directory on the encrypted root partition. This caused the failure. So, instead of editing /etc/default/grub move the contents of the boot directory to a separate unencrypted /boot partition (note that the EFI Partition is mounted into /boot/efi) and then install Grub normally:
apt-get install --reinstall grub-efi-amd64
update-grub

If you use this solution, you will be prompted only once for a password to decrypt your encrypted partition.

  • I have the exact same setup and problem as you but I don't understand your Update comment. Is the solution above it even needed anymore or a valid way? What do you mean by move the contents of the boot directory. I tried cp -r /boot/* /boot/efi/ and got a problem with a mismatching UUID... – mxmlnkn Jan 27 '19 at 10:44
  • @mxmlnkn cp -r /boot/* /boot/efi/ is wrong and you should revert what you copied. What I mean by the update comment is that you should do steps 1-3. Then mount the unencrypted boot-partition to, for example, /mnt and copy everything from /boot (except /boot/efi) to /mnt. Then unmount the boot-partition from /mnt and mount it to /boot. Then run apt-get install --reinstall grub-efi-amd64 and update-grub. – SergiyKolesnikov Jan 27 '19 at 18:50
0

For UEFI boot, with GPT, you need not create BIOS BOOT Partition (with BIOS_GRUB flag). For non-UEFI boot (with BIOS) and with GPT, you need BIOS BOOT Partition. Read https://wiki.archlinuxjp.org/index.php/GRUB#UEFI_.E3.82.B7.E3.82.B9.E3.83.86.E3.83.A0

I want to know the current boot configuration of your PC. Boot with Boot-repair and generate Boot-info URL and post the generated URL.

0

The solution is the following: the file system keeps reading the old 1.0 mb partitions where the grub loader was installed in precedence. Even if you try to resize or delete partitions they wont inglobate that free space and your partition table remains flawed. To solve the issue you have to select in the kali installer partitioner the ENTIRE VOLUME or hard disk, and not the partitions, then CHANGE THE FILE SYSTEM for once to ms-dos, and create a new partition table. After formatting the volume and attempring an install, the new filesystem that doesnt use these partitions will get rid of them and after this overwriting install, that might not work yet, you can start over selecting again the correct filesystem which is gpt i think, and the partitioner this time will delete whole disk and re partition it correctly. The computer will now be repaired and will be able to boot without problems with all of its space available. Takes some time and you have to give away your dual boot for this time but it fixes all the issue. Trust me it works! The whole issue is caused by the fact that kali partitioner is a basic one just to clean disks and install system, its not a complete one like gparted and thus has less abilities to fix these problems which have to be addressed manually.

0

Solve while still in the installer

I was able to solve this issue while installing Debian Stretch via USB stick on a Dell Precision 5820 with drive encryption. I was not dual booting Windows, but I believe the solution would work if I was. I had already disabled secure boot. I was getting the same error about installing grub in dummy while installing, but I did not exit the installer.

I believe the issue, was where /boot and /boot/efi were mounted. I solved the problem during the install by going back to the partitioning step and changing my partition table with manual partitioning.

First setup boot partitions unencrypted:

  • EFI System Partition (ESP) with /boot/efi mounted - This is required for UEFI boot systems
  • biosgrub partition, or Reserved BIOS boot area - This becomes space for the bootloader files. You will not be able to make this partition "bootable" because the ESP is bootable.

It is imperative that these be unencrypted, and it is recommended that they are at the beginning of the disk or available free space with other partitions following.

Set up other partitions and encrypt if you want

If you are dual booting Windows, your Windows partition should show up during manual partitioning, and you should not have to change anything for it. I recommend following Debian's recommended partitioning scheme for your remaining partitions.

Other notes

You may have to clear the data on the partitions (other than your Windows partition!) for this to work, and go through the installer steps between partitioning and installing GRUB again so that the installer puts files in the correct location. If you proceed right to installing GRUB again, this solution may not work.

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.