3

I'm transferring some data from my desktop to my laptop trough wifi. My home network is managed with windows 7 homegroup

When my 2 pc's are connected via my router (with internet access) i get max 200 KB/s and when i create a ad hoc wifi i get 1.5 MB/s

why is that...

(copying data via network name ex: \\PC2)

6

Because ad-hoc connection protocol is simpler than access-point connection (via router). In ad-hoc case you have only two entities that talk to each other, while in access-point case there can be many entities and protocol has more overhead to be able to handle that. This overhead is still present even if only two computers connect.

Another reason is that transferring files is usually done via TCP protocol -- the other party has to send response to confirm that data was delivered. So the data has to travel to the other party and back though the router, rather than directly.

Internet has nothing to do with file transfer, unless it's one more party connected wirelessly to the router and also requires some air time.

  • 8
    I should also note, that 200 KB/s is very low speed for wireless router and the difference from ad-hoc connection should be not perceivable at all (e.g. 8 vs 7.8 MB). If only computers that connect to router are the one you are transferring files between, then you might want to check your router settings. Something must be wrong. – Sergiy Belozorov Mar 2 '10 at 22:05
1

What is your set up? Do both laptop and desktop have wifi? Is it 802.11g, and the router old with 802.11b? Because when I was moving large files around with b, I was topping out at about 300KBps, but via ad hoc they would be running g, which is much faster.

  • it's 802.11g both – user29951 Mar 9 '10 at 20:51
0

I would say something is wrong with your router. Sergiy is right 200K is way slower then it should be.

A small difference would be expected as your data travels to the router and the router has to make a decision about it and then sends it off. With adhoc there is only 1 place for it to go and that/'s where it goes.

0

i'm inclined to think that the problem may be with the windows 7. For me, i get the same ~300kbps via router and >1MBps speed via ad hoc. 300kBps is definitely far too slow no matter what router you use. i've tried lan transfers at work and at home via different routers and same result. However, i'm still trying to find a solution myself, but my efforts have been more towards windows 7 settings than anything else...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.