0

Some pages in IE 11, that seem to be UTF-8, are not displaying correctly. The same page displays correctly in Mozilla Firefox. I first noticed this in Amazon.com on the Orders page (pretty much any of them), but pressing the F5 button causes the page to then display correctly. However, in some other pages F5 has no effect. On this page: when I click on any of the download links (nice fonts btw), I get a garbage page that looks like this:

Screenshot



I have tried Tools > Internet Options > Advanced > and clicking on Restore Advanced Settings and Reset under Reset Internet Explorer settings. Neither had any effect. I have also tried setting UTF-8 and Auto Select in View > Encoding. Google searches haven't turned up anything helpful.

This seems to have started when I created a new user profile on my machine (Windows 10 x64) and transferred all my files there, but I get the same issue when I display this page using the built-in Administrator profile.

If anyone has any ideas how to fix this, it would be much appreciated.

Machine details:

  • Windows 10 x64 AU
  • 32 GB 2666 DDR4
  • ASUS Z170-AR motherboard
  • AMD R9-290x 8GB

Thanks

0

This MSIE behaviour has nothing to do with (character) encoding. Internet Explorer 11 simply does not recognise MIME types properly.

More info and guides in Introduction to Feature Controls, Handling MIME Types in Windows Internet Explorer and Internet Explorer Policy Settings articles.

Links under Ham Radio Fonts are links to true type font files (TTF, primarily binary ones). Their MIME type should be application/octet-stream - default if data is binary.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.