3

I'm currently using Intellij IDEA with IdeaVim. Sometimes when I type the type screen freezes (like you do in vim with Ctrl+S) but Ctrl+Q is not working. When i restart IntelliJ idea it works again...

I searched on web but there is always someone asking do you use IdeaVim? but they do not say what to do if the answer is yes. There should be a better way than restarting. Thank you...

Using Ubuntu (GNU Linux) Intellij Idea 16

2
  • What OS do you use ? – Anton Dozortsev Dec 12 '16 at 17:14
  • @AntonDozortsev Linux – cagince_ Dec 13 '16 at 20:45
1

This is known bugs:

And someone found a workaround. Add below line a the top of the idea.sh file:

export XMODIFIERS=""

Hope this will help you.

1
  • 1
    Mine was caused by IBUS links were enough to solve the problem, Thank you. – cagince_ Dec 16 '16 at 7:12
0

Turn off Vim Emulator from Tools in the intelliJ:

enter image description here

0

This workaround seems help

In top menu -> Help -> Edit Custom VM Options...

add this 2 lines at bottom

-Drecreate.x11.input.method=true
-Dawt.ime.disabled=true

then restart IDE

P/S: My environment: Ubuntu 20.04, PhpStorm 2019.1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.