0

I've been using VirtualBox (currently on version 4.2.18.r88780, says I'm up to date when I search for updates) for years on my Win 7 laptop. However, after I upgraded to Win 10 all my VMs stopped working and I'm new ones are not starting either. I can't point out a single error message because I get different errors depending on what I'm doing.

I was able to "fix" one of my old VMs (a 32-bit Win 7 guest OS) by reducing the number of CPUs to one in the machine settings. However, I didn't have the same luck with other machines (I have a bunch with Win 8.1, and Ubuntu 14 mainly).

I also tried to create new VMs (a 32 bit ubuntu and a 64 bit ubuntu) in the hope of importing the virtual disks from the broken machines, but I'm also getting errors with that.

The same host computer (with the same hardware and same BIOS version and setup) was running VirtualBox machines perfectly when it had Win 7. After Win 10 everything just stopped working.

A few examples: I just created a 64bit machine where I was trying to install ubuntu 16. However, as soon as I load the ubuntu iso in it I get this error:

Cannot load R0 module C:\Program Files\Oracle\VirtualBox/VBoxDD2R0.r0: supLoadModule returned VERR_LDR_MISMATCH_NATIVE (VERR_LDR_MISMATCH_NATIVE).
Código Resultado: E_FAIL (0x80004005)
Componente: Console
Interfaz: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

And this is when I try to open an existing Win7 machine (which was definitely working before my upgrade to win10):

VT-x features locked or unavailable in MSR. (VERR_VMX_MSR_LOCKED_OR_DISABLED).
Código Resultado: E_FAIL (0x80004005)
Componente: Console
Interfaz: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

So my question is: is there any hope I can run my old (or new) VMs without changing my computer setup? I wouldn't like to mess with the BIOS or anything else, since it wasn't needed before so I don't see why it should be needed now.

  • Check if Hyper-V related services are running. If you don't want to run them you can stop and disable them. Alternatively, you can copy your boot option using bcdedit and set one version to boot with Hyper-V running and another without it running. – Enigman Dec 11 '16 at 4:33
  • It seems odd that virtualbox would report that you were up to date when that latest version is v5.1.10. Might be worth reinstalling from a fresh download of that software. – AlwaysLearning Dec 11 '16 at 5:13
  • you use an very old virrualbox version. Update to the latest version 5.1 : virtualbox.org/wiki/Downloads – magicandre1981 Dec 11 '16 at 7:40
0

Only VirtualBox versions 5.0 and up work on Windows 10.

I suggest you uninstall the current installation, reboot, download the latest version from here, and install it.

Your current installation is probably corrupt as it cannot check for updates. Re-installing is recommended.

|improve this answer|||||
  • 1
    Yep, definitely an update solved the problem. Not sure why it kept saying there were no updates. Thanks! – Floella Dec 12 '16 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.