0

Earlier today I was doing something when I noticed my headphone mic wasn't working. So, I did some troubleshooting, went to my motherboard's driver site, and downloaded some drivers that I thought needed to be downloaded. After a few unsuccessful attempts, I got the software back and decided to use a webcam mic instead.

Then, I opened up Star Wars Battlefront and joined a game. After a few seconds of playing in a game, I suddenly got disconnected, so I retired. Same thing. Then I decided to check if it might be an internet speed problem, so I went to speedtest.net. The download speeds were fine, but when it came to upload, it didn't move. I tried restarting, with Windows troubleshooting and updating, Ethernet driver reinstalling, even tried disabling the advanced thing with my ethernet (offload or something, I forgot). No luck. I tried the most common answers to similar problems, but none of them worked. Also tried disabling the antivirus, no luck

Does anyone have any solution?

Some things to note:

  • after deleting the device in device manager and reinstalling, I have little upload speed for about a minute, then nothing

  • This is a computer problem. I tested on other devices and they were fine.

  • My network setup is like this: Computer <-internal house wiring-> ethernet multiconnector (4 ports) (forgot exact name) (problem could be with this, but unconfirmed) <-internal house wiring-> Google OnHub <-internal house wiring-> Xfinity high speed wifi/modem <-internal house wiring-> world

  • My computer is an Asus z97 mk2 with a gtx 960, 16gb ram, 2 tb hard drive, and an i7 4th gen. My drivers should be updated.

  • I have cfospeed, and this has caused a similar problem with others, however I have had it for a while and haven't updated it lately. I also have some iobit programs, but they don't optimize network.

3
  • 1
    Power off the router/modem, all other network devices, switches, wifi APs etc, then the computer. Wait 2 minutes. Power up from "nearest the outside world" first, waiting 2 mins between each for it to initialise, ending at your puter. Test again. Don't use "optimisers" they rarely make anything better. – Tetsujin Dec 11 '16 at 8:55
  • Could try "rolling back" any changes (drivers, etc) that were made, to a time back when everything was working well – Xen2050 Dec 11 '16 at 9:19
  • In your first bullet point you say "I have so.e upload speed", what does that actually mean? – Mokubai Dec 11 '16 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.