1

I have recently acquired two SUN Quad-port Gigabit low-profile ethernet NICs (PCI-Express 2.0 x4) for a home-lab setup. These are rebrands of the Intel I350-T4 adapter, which has full, cross-platform driver support. I have had the following success with it and know the cards are good:

PXE BOOT:

BIOS-Recognized for PXE boot on my ASUS M5A99FX-PRO and Gigabyte GA-X99P-SLI boards. Also BIOS-recognized on an old Dell LGA775 motherboard.

LINUX:

Full Linux support on Debian 7, 8, Turnkey Linux and OpenMediaVault, running on the above ASUS boards and the old Dell Optiplex board.

WINDOWS:

Card does not work on any Windows machine I have tested, which are the above 3 hardware setups. Currently attempting on a Windows 10 x64 Enterprise machine, but have had the same errors in Server 2012 R2. Oracle says to use the Intel I350-T4 driver (they are the same card), which installs but instead tries to apply itself to my on-board Intel NIC. In the other boards, this driver refuses to install because it does not see an Intel NIC. Extra info: My workstation is on a 2012R2 domain and I'm using a domain admin account with full rights. Have also tried off a domain using local admin.

I have tried the following:

  • Forcing Windows to use the generic I350 drivers, but device won't power on.
  • Uninstall/reinstall Intel drivers, but this had the same outcome.
  • Intel Driver Detect, but it didn't find anything besides the X99 chipset drivers I'm already using.
  • Pointing it at the driver CAB, which didn't work.

The error message I get from Device Manager can be seen in the screenshot here: enter image description here

UPDATE: I have also attempted to use the "Sun Quad Port GbE PCIe 2.0 Low Profile Adapter, UTP" drivers listed as generics in Windows under "Intel Corporation." This is the exact model of the card. However, I get another problem, error code 10. See photo.

enter image description here

Even though this card reports that it is not working or installed, it is "powered on" because I get both link and speed/duplex lights lit when I connect it to my switch. Any help very much appreciated, as I need to use this card in a dual-boot situation between Debian and Windows 10 on my primary workstation.

  • 1
    You have called Oracle and asked them where they horde the drivers? – Ramhound Dec 11 '16 at 21:26
  • No harm in trying -- I'll do that now! I know this is a good adapter as it works seamlessly in Debian. Maybe there's a reason these rebrands are so inexpensive. EDIT: The Oracle hardware support line is literally someone's cellphone voicemail. – Daedalus Dec 11 '16 at 21:31
  • I can tell you that, they will have you download this one. Be sure you, "If the Found New Hardware Wizard screen is displayed, click Cancel", and then "The autorun utility automatically runs after you have extracted the files." Be sure you try extracting the files manually, tell Windows you want to point to the .inf manually the installer might be screwed up knowing Intel/Oracle. – Ramhound Dec 11 '16 at 21:33
  • Installed via v1q65x64.inf with above mentioned package, detected proper (signed) drivers, installed, continues to throw error code 10. – Daedalus Dec 11 '16 at 22:00
  • You have tried a different PCI-E slot I presume? – Ramhound Dec 11 '16 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.